zoukankan      html  css  js  c++  java
  • POJ 2524 Ubiquitous Religions【并查集入门】

    Time Limit: 5000MS   Memory Limit: 65536K
    Total Submissions: 19292   Accepted: 9472

    Description

    There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in. 

    You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.

    Input

    The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.

    Output

    For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.

    Sample Input

    10 9
    1 2
    1 3
    1 4
    1 5
    1 6
    1 7
    1 8
    1 9
    1 10
    10 4
    2 3
    4 5
    4 8
    5 8
    0 0
    

    Sample Output

    Case 1: 1
    Case 2: 7
    

    Hint

    Huge input, scanf is recommended.

    Source


    题意:求出有多少个不同的连通分量即可。

    /*
    J	
    Accepted	
    328 KB	
    297 ms	
    C++	
    699 B	
    2013-04-06 22:01:58
    */
    #include<cstdio>
    
    const int maxn = 50000+10;
    
    int p[maxn];
    
    int find(int x)
    {
        return x == p[x] ? x : p[x] = find(p[x]);
    }
    
    void Union(int x, int y)
    {
        x = find(x);
        y = find(y);
    
        if(x == y) return;
        else p[x] = y;
    }
    int main()
    {
        int n, m;
        int C = 0;
        while(scanf("%d%d", &n, &m) != EOF)
        {
            if(n == 0 && m == 0) break;
    
            for(int i = 1; i <= n; i++) p[i] = i;
    
            int x, y;
            while(m--)
            {
                scanf("%d%d", &x, &y);
                Union(x, y);
            }
    
            int ans = 0;
    
            for(int i = 1; i <= n; i++)
            {
                if(i == p[i]) ans++;
            }
            printf("Case %d: %d\n", ++C, ans);
        }
        return 0;
    }
    


  • 相关阅读:
    测试随笔
    ECNU 3530 和你在一起
    ECNU 1030 母牛生小牛
    ECNU 3081 购房还款
    PPP模式下的融资结构优化
    决策树分类
    关联规则-R语言实现
    中国快递包裹总量的预测-基于SARIMA模型
    LeetCode 2 :Swap Nodes in Pairs
    2018092609-2 选题 Scrum立会报告+燃尽图 04
  • 原文地址:https://www.cnblogs.com/freezhan/p/3219104.html
Copyright © 2011-2022 走看看