zoukankan      html  css  js  c++  java
  • POJ 1611 The Suspects【并查集入门】

    Time Limit: 1000MS   Memory Limit: 20000K
    Total Submissions: 17149   Accepted: 8272

    Description

    Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 
    In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 
    Once a member in a group is a suspect, all members in the group are suspects. 
    However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

    Input

    The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 
    A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

    Output

    For each case, output the number of suspects in one line.

    Sample Input

    100 4
    2 1 2
    5 10 13 11 12 14
    2 0 1
    2 99 2
    200 2
    1 5
    5 1 2 3 4 5
    1 0
    0 0

    Sample Output

    4
    1
    1

    Source


    /*
    并查集入门题目
    题意:给你 n 个学生,分成 m 组
          在同一组的人中均有关系。
          求与编号为 0 的同学有关系的学生人数
          注意:n 个学生的编号为 0~n-1
               一个学生可以属于多个小组,那么这多个组的人均有关系
    C
    Accepted
    364 KB
    16 ms
    C++
    788 B
    2013-04-06 21:41:59
    */
    #include<cstdio>
    
    const int maxn = 30000+10;
    int p[maxn]; //存父节点
    
    int find(int x) //找父
    {
        return x == p[x] ? x : p[x] = find(p[x]);
    }
    
    void Union(int x, int y) //联合
    {
        x = find(x);
        y = find(y);
    
        if(x == y) return;
        else p[x] = y;
    }
    
    int main()
    {
        int n, m;
        while(scanf("%d%d", &n, &m) != EOF)
        {
            if(n == 0 && m == 0) break;
    
            for(int x = 0; x < n; x++) p[x] = x; //初始化自己为自己的父亲
    
            int groupNum, x, y;
            while(m--)
            {
                scanf("%d%d", &groupNum, &x); //输入组的成员数,和第一个组员
                while(--groupNum)
                {
                    scanf("%d", &y);
                    Union(x, y); //每个组员与第一个组员联合
                }
            }
    
            int ans = 1; //编号为 0 的学生自己与自己有关系
            for(int x = 1; x < n; x++) //从第二个人开始找
            {
                if(find(x) == find(0)) ans++;
            }
            printf("%d\n", ans);
        }
        return 0;
    }
    


  • 相关阅读:
    linux_crontab_定时删除
    bigdata_zookeeper 可视化界面zkui
    bigdata_ Kafka集群模式部署
    大数据_zookeeper环境搭建中的几个坑
    实战-130W表增加字段耗时
    每天一个linux命令
    nginx重启报找不到nginx.pid的解决方法
    log4j配置
    mysql select 1
    查看mysql语句运行时间
  • 原文地址:https://www.cnblogs.com/freezhan/p/3219105.html
Copyright © 2011-2022 走看看