zoukankan      html  css  js  c++  java
  • PKU2503_map应用

    Description

    You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.

    Input

    Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.

    Output

    Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as "eh".

    Sample Input

    dog ogday
    cat atcay
    pig igpay
    froot ootfray
    loops oopslay
    
    atcay
    ittenkay
    oopslay
    

    Sample Output

    cat
    eh
    loops
    

    Hint

    Huge input and output,scanf and printf are recommended.
    #include<map> 
    #include<cstdio>
    #include<iostream>
    #include<string>
    using namespace std;
    int main()
    {
           map<string,string> m;
           string s;
           while(getline(cin,s)){
               if(s.empty()) break;
               int p,sz=s.size();
            p=s.find(' ');
            string a=s.substr(0,p);
            string b=s.substr(p+1,sz-p-1);
            m[b]=a;
        }
        string t;
        while(cin>>t){
            if(!m[t].empty())
                cout<<m[t]<<endl;
            else cout<<"eh"<<endl;
        }
    }
  • 相关阅读:
    巡风安装笔记
    泛微ecology OA系统某接口存在数据库配置信息泄露漏洞
    Apache Solr Velocity模板远程代码执行复现
    泛微OA系统多版本存在命令执行漏洞
    各种浏览器UA值
    使用python合并excel
    疑难杂症----udf提权无法导出.dll
    疑难杂症----windows7
    Nmap的使用
    Sqlmap的使用
  • 原文地址:https://www.cnblogs.com/freinds/p/6744470.html
Copyright © 2011-2022 走看看