zoukankan      html  css  js  c++  java
  • PKU2503_map应用

    Description

    You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.

    Input

    Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.

    Output

    Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as "eh".

    Sample Input

    dog ogday
    cat atcay
    pig igpay
    froot ootfray
    loops oopslay
    
    atcay
    ittenkay
    oopslay
    

    Sample Output

    cat
    eh
    loops
    

    Hint

    Huge input and output,scanf and printf are recommended.
    #include<map> 
    #include<cstdio>
    #include<iostream>
    #include<string>
    using namespace std;
    int main()
    {
           map<string,string> m;
           string s;
           while(getline(cin,s)){
               if(s.empty()) break;
               int p,sz=s.size();
            p=s.find(' ');
            string a=s.substr(0,p);
            string b=s.substr(p+1,sz-p-1);
            m[b]=a;
        }
        string t;
        while(cin>>t){
            if(!m[t].empty())
                cout<<m[t]<<endl;
            else cout<<"eh"<<endl;
        }
    }
  • 相关阅读:
    pands数据框(DataFrame)02
    mysql 临时表
    【转】Mysql 多表连接查询的执行细节 (一)
    【转】cuckoo hash
    [转]全域哈希
    【转】 bloom filter
    【转】bitmap
    golang 反汇编代码阅读-- defer
    assignment3
    Lecture 12: Visualizing and Understanding
  • 原文地址:https://www.cnblogs.com/freinds/p/6744470.html
Copyright © 2011-2022 走看看