zoukankan      html  css  js  c++  java
  • poj2240floyd算法

    Arbitrage
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 11589   Accepted: 4866

    Description

    Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent. 

    Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not. 

    Input

    The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible. 
    Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.

    Output

    For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".

    Sample Input

    3
    USDollar
    BritishPound
    FrenchFranc
    3
    USDollar 0.5 BritishPound
    BritishPound 10.0 FrenchFranc
    FrenchFranc 0.21 USDollar
    
    3
    USDollar
    BritishPound
    FrenchFranc
    6
    USDollar 0.5 BritishPound
    USDollar 4.9 FrenchFranc
    BritishPound 10.0 FrenchFranc
    BritishPound 1.99 USDollar
    FrenchFranc 0.09 BritishPound
    FrenchFranc 0.19 USDollar
    
    0
    

    Sample Output

    Case 1: Yes
    Case 2: No

    找到一个圈,使得圈上边的权值之积>1,弗洛伊德算法可以求最短路径,改一下,也可以求最大乘积,如果最后出现某个w[i][i]>1,就说明存在这样的圈

    #include <stdio.h>
    #include <iostream>
    #include <string.h>
    #include <string>
    #define INF    1e8
    using namespace std;
    int n, m;
    string s[30];
    double w[30][30];
    int getidx(const string &name)
    {
        for(int i = 0; i < n; i++){
            if(s[i] == name){
                return i;
            }
        }
        printf("error\n");
        return -1;
    }
    void floyd()
    {
        for(int k = 0; k < n; k++){
            for(int i = 0; i < n; i++){
                for(int j = 0; j < n; j++){
                    if(w[i][j] < w[i][k] * w[k][j]){
                        w[i][j] = w[i][k] * w[k][j];
                    }
                }
            }
        }
    }
    int main(int argc, const char *argv[])
    {
        int cnt = 1;
        while(cin >> n && n != 0){
            for(int i = 0; i < n; i++){
                cin >> s[i];
            }
            memset(w, 0, sizeof(w));//init
            for(int i = 0; i < n; i++){
                w[i][i] = 1;
            }
            cin >> m;
            string tmp1, tmp2;
            double tmpw;
            for(int i = 0; i < m; i++){
                cin >> tmp1 >> tmpw >> tmp2;
                w[getidx(tmp1)][getidx(tmp2)] = tmpw;
            }
            floyd();
            int i;
            for(i = 0; i < n; i++){
                if(w[i][i] > 1){
                    printf("Case %d: Yes\n", cnt);
                    break;
                }
            }
            if(i == n){
                printf("Case %d: No\n", cnt);
            }
            cnt++;
        }
        return 0;
    }

    其实我还没有完全理解,可是就AC了……(用G++超时,然后跑到discuss版看了一下,有人说C++更快,果然,79MS通过……怎么差这么多)

    floyd算法用的是算法导论25章习题25.2-4的改进版(空间从n^3减少到n^2)

  • 相关阅读:
    容斥原理算法总结(bzoj 2986 2839)
    网络流系列算法总结(bzoj 3438 1061)
    bzoj 2746: [HEOI2012]旅行问题 AC自动机fail树
    bzoj 3283: 运算器 扩展Baby Step Giant Step && 快速阶乘
    计算几何考场绘图技巧
    bzoj 1845: [Cqoi2005] 三角形面积并 扫描线
    bzoj 3784: 树上的路径 堆维护第k大
    BZOJ 1231: [Usaco2008 Nov]mixup2 混乱的奶牛
    BZOJ 1112: [POI2008]砖块Klo
    BZOJ 1003: [ZJOI2006]物流运输trans DP+最短路
  • 原文地址:https://www.cnblogs.com/fstang/p/2808208.html
Copyright © 2011-2022 走看看