zoukankan      html  css  js  c++  java
  • ACMDP之最长公共子序列长度—HDU1159

    Common Subsequence

    Problem Description
    A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
    The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
     
    Sample Input
    abcfbc abfcab programming contest abcd mnp
     


    Sample Output
    4 2 0 这道题就是求两个字符串的最长公共子序列的长度,如图: 求最长公共子序列长度,可以分阶段,先找第一串第一个字符与第二串的长度, 再找第一串前两个字符与第二串的最长公共子序列长度, 以此类推。。。。 上图是abcfb 与 abfcab,求这两串的最长公共子序列 图中设置的是二维数组,格内的数为行列号,比如,第一个00表示第0行第0列, 由图可以很清晰的看出表达式: 设 abcfb为str1[6],abfcab为str2[7],i为行号,j为列号。 当str1[i]==str2[j]时,长度为 二维数组[i-1][j-1]+1, 不相等时为上格子与前一格子最大值(即max(二维数组[i-1][j],二维数组[i][j-1]); 这样算下来,最右下角的必定为最长公共子序列的长度。   代码如下:
    #include <iostream>
    #include <string>
    using namespace std;
    
    int arr[1001][1001];
    
    int main()
    {
        int i,j,s1,s2;
        char str1[1001],str2[1001];
        
        while(cin>>str1>>str2)
        {
            s1=strlen(str1);
            s2=strlen(str2);
            
            for(i=1;i<=s1;++i)            // 让刚开始i=1,j=1可以避免判断边界值的时候,使代码简练
                for(j=1;j<=s2;++j)
                {
                    
                    if(str1[i-1]==str2[j-1])
                        arr[i][j]=arr[i-1][j-1]+1;
                    else
                        arr[i][j]=(arr[i-1][j]>arr[i][j-1])?arr[i-1][j]:arr[i][j-1];
                }
    
            cout<<arr[s1][s2]<<endl;
        }
        return 0;
    }
    


     
  • 相关阅读:
    Javascript 函数表达式
    当你在浏览器地址栏输入一个URL后回车,将会发生的事情?
    Angularjs 脏值检测
    Angularjs 双向绑定机制解析
    AngularJS 初用总结
    从jquery里的$.ajax()到angularjs的$http
    XSS攻击及防御
    很赞的源码平台
    GET和POST
    [转]xxx.hbm.xml模版
  • 原文地址:https://www.cnblogs.com/fuhaots2009/p/3437079.html
Copyright © 2011-2022 走看看