zoukankan      html  css  js  c++  java
  • Milk(杭电1070)

    Milk

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 13983    Accepted Submission(s): 3447


    Problem Description
    Ignatius drinks milk everyday, now he is in the supermarket and he wants to choose a bottle of milk. There are many kinds of milk in the supermarket, so Ignatius wants to know which kind of milk is the cheapest.

    Here are some rules:
    1. Ignatius will never drink the milk which is produced 6 days ago or earlier. That means if the milk is produced 2005-1-1, Ignatius will never drink this bottle after 2005-1-6(inclusive).
    2. Ignatius drinks 200mL milk everyday.
    3. If the milk left in the bottle is less than 200mL, Ignatius will throw it away.
    4. All the milk in the supermarket is just produced today.

    Note that Ignatius only wants to buy one bottle of milk, so if the volumn of a bottle is smaller than 200mL, you should ignore it.
    Given some information of milk, your task is to tell Ignatius which milk is the cheapest.
     

    Input
    The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
    Each test case starts with a single integer N(1<=N<=100) which is the number of kinds of milk. Then N lines follow, each line contains a string S(the length will at most 100 characters) which indicate the brand of milk, then two integers for the brand: P(Yuan) which is the price of a bottle, V(mL) which is the volume of a bottle.
     

    Output
    For each test case, you should output the brand of the milk which is the cheapest. If there are more than one cheapest brand, you should output the one which has the largest volume.
     

    Sample Input
    2 2 Yili 10 500 Mengniu 20 1000 4 Yili 10 500 Mengniu 20 1000 Guangming 1 199 Yanpai 40 10000
     

    Sample Output
    Mengniu Mengniu
    #include<stdio.h>
    #include<algorithm>
    using namespace std;
    struct st
    {
        char name[105];
        double price;
        double v;
        double pingjun;
        double pj;
    }data[105]; 
    int cmp(st a,st b)
    {
        return a.pj<b.pj;
    }
    int main()
    {
        int test;
        scanf("%d",&test);
        while(test--)
        {
            int n;
            scanf("%d",&n);
            for(int i=0;i<n;i++)
            data[i].pingjun=10000000;
            for(int i=0;i<n;i++)
            {
               scanf("%s %lf %lf",data[i].name,&data[i].price,&data[i].v);
            }
            for(int i=0;i<n;i++)
            {
                if(data[i].v<200)
                continue;
                else
                {
                    data[i].pingjun=data[i].v<=1000?

    data[i].price/int(data[i].v/200):data[i].price/5; } } for(int i=0;i<n;i++) { data[i].pj=data[i].pingjun; } double k=0; sort(data,data+n,cmp); int j; for(int i=0;i<n;i++) { if(data[i].pingjun==data[0].pj) { if(k<data[i].v) { k=data[i].v; j=i; } } } printf("%s ",data[j].name); } return 0; }



  • 相关阅读:
    [centos6.5]添加eclipse快捷方式
    Maven 实用命令和技巧
    MyEclipse 15 集成SVN
    Eclipse不给提示no default proposals
    Eclipse快捷键
    Maven打包排除不需要的文件。
    MySQL用法
    Idea反向生成JavaBean
    java.lang.NoClassDefFoundError: [Lorg/hibernate/engine/FilterDefinition
    Spring+SpringMVC+MyBatis+Maven 服务端XML配置
  • 原文地址:https://www.cnblogs.com/gavanwanggw/p/6905248.html
Copyright © 2011-2022 走看看