zoukankan      html  css  js  c++  java
  • poj 1331 Multiply

    Multiply
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 5179   Accepted: 2773

    Description

    6*9 = 42" is not true for base 10, but is true for base 13. That is, 6(13) * 9(13) = 42(13) because 42(13) = 4 * 131 + 2 * 130 = 54(10). 

    You are to write a program which inputs three integers p, q, and r and determines the base B (2<=B<=16) for which p * q = r. If there are many candidates for B, output the smallest one. For example, let p = 11, q = 11, and r = 121. Then we have 11(3) * 11(3) = 121(3) because 11(3) = 1 * 31 + 1 * 30 = 4(10) and 121(3) = 1 * 32 + 2 * 31 + 1 * 30 = 16(10). For another base such as 10, we also have 11(10) * 11(10) = 121(10). In this case, your program should output 3 which is the smallest base. If there is no candidate for B, output 0. 

    Input

    The input consists of T test cases. The number of test cases (T ) is given in the first line of the input file. Each test case consists of three integers p, q, and r in a line. All digits of p, q, and r are numeric digits and 1<=p,q, r<=1,000,000.

    Output

    Print exactly one line for each test case. The line should contain one integer which is the smallest base for which p * q = r. If there is no such base, your program should output 0.

    Sample Input

    3
    6 9 42
    11 11 121
    2 2 2
    

    Sample Output

    13
    3
    0
    

    题意:给你三个数字p,q,r,问在哪个最小的进制下p*q=r成立;

    注意:假设在k进制下p,q,r的每位上的数字应该要小于k;

    #include <iostream>
    #include <string.h>
    using namespace std;
    int change(char *a,int k){
    	int len=strlen(a);
    	int ans=0;
    	for (int i=0;i<len;i++){
    		ans = ans*k + a[i]-'0';
    	}
    	return ans;
    }
    bool isBig(char *a,int k){
    	int len=strlen(a);
    	for (int i=0;i<len;i++){
    		if (a[i]-'0'>=k)
    			return false;
    	}
    	return true;
    }
    int main(){
    	char a[10],b[10],r[10];
    	int t,i;
    	cin>>t;
    	while (t--){
    		cin>>a>>b>>r;
    		for (i=2;i<=16;i++){
    			if (isBig(a,i)==true && isBig(b,i)==true && isBig(r,i)==true){
    				int aa = change(a,i);
    				int bb = change(b,i);
    				int rr = change(r,i);
    				long long ans = aa*bb;
    				long long ans2 = rr;
    				if (ans==ans2)
    					break;
    			}
    			
    		}
    		if (i==17)
    			i=0;
    		cout<<i<<endl;
    	}
    	return 0;
    }




  • 相关阅读:
    poj3635(最短路)
    poj 3041( 最大匹配)
    poj 3522(生成树)
    poj 1904(强连通分量)
    poj 2446(二分匹配)
    poj 2400(最小权匹配)
    poj 2175(费用流消圈)
    poj 1256(搜索)
    poj 2195(最小费用流)
    poj 3613(最短路)
  • 原文地址:https://www.cnblogs.com/gccbuaa/p/6872261.html
Copyright © 2011-2022 走看看