zoukankan      html  css  js  c++  java
  • [ACM] POJ 3258 River Hopscotch (二分,最大化最小值)

    River Hopscotch
    Time Limit: 2000MS   Memory Limit: 65536K
    Total Submissions: 6697   Accepted: 2893

    Description

    Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L).

    To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

    Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to Mrocks (0 ≤ M ≤ N).

    FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set ofM rocks.

    Input

    Line 1: Three space-separated integers: LN, and M 
    Lines 2..N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

    Output

    Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing M rocks

    Sample Input

    25 5 2
    2
    14
    11
    21
    17

    Sample Output

    4

    Hint

    Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).

    Source


    解题思路:

    这种题目不好理解啊。。。有N+2块石头,给出最后一块到第一块的距离L,输入中间N块石头到第一块石头的距离,要求移除M块石头,使相邻两块石头的距离中的最小值尽可能得大。。。

    思路还是二分,找上界和下界。。只是实在是不好理解。。以下代码中

    有这种语句

    for(int i=1;i<=N;i++)
            {
                if(temp[i]<=mid)//当前距离小于等于mid,注意mid是当前最小值,假设不删除第i块石头,那么temp[i]则成了理应的最小值
                {
                    cnt++;
                    temp[i+1]=temp[i+1]+temp[i];
                }
            }
    为什么是temp[i]<=mid,为什么等于也能够呢??假设等于也删除的话,那不意味着不存在相邻两块石头的距离为mid了吗?? 想了好久也没想出来为什么。

    各位大侠假设知道为什么。。麻烦在以下评论中留言,感激不尽。。

    代码:

    #include <iostream>
    #include <stdio.h>
    #include <algorithm>
    using namespace std;
    const int maxn=50010;
    int dis[maxn];
    int temp[maxn];
    
    int main()
    {
        int L,N,M;
        scanf("%d%d%d",&L,&N,&M);
        dis[0]=0;
        dis[N+1]=L;
        int left=1000000000,right=-1;
        for(int i=1;i<=N;i++)
        {
            scanf("%d",&dis[i]);
        }
        N++;
        sort(dis,dis+N+1);
        
        for(int i=N;i>=1;i--)
        {
            dis[i]=dis[i]-dis[i-1];
            if(left>dis[i])
                left=dis[i];
            if(right<dis[i])
                right=dis[i];
        }//dis[i]存的是第i块石头到第i-1块石头的距离
        
        while(left<right)
        {
            for(int i=1;i<=N;i++)
                temp[i]=dis[i];
            int mid=(left+right)/2;
            int cnt=0;
            for(int i=1;i<=N;i++)
            {
                if(temp[i]<=mid)//当前距离小于等于mid,注意mid是当前最小值,假设不删除第i块石头,那么temp[i]则成了理应的最小值
                {
                    cnt++;
                    temp[i+1]=temp[i+1]+temp[i];
                }
            }
            if(cnt<=M)
                left=mid+1;
            else
                right=mid;
        }
        cout<<right<<endl;
        return 0;
    }
    




  • 相关阅读:
    团队项目-典型用户及用户场景分析
    课堂小练习-找“水王”
    课堂小练习—电梯
    团队项目—用户需求调研报告
    课堂小练习
    团队项目的NABC
    梦断代码—随笔三
    梦断代码—随笔二
    结对开发5_循环二维数组最大字数组
    结对开发4_循环数组的最大值
  • 原文地址:https://www.cnblogs.com/gcczhongduan/p/3982214.html
Copyright © 2011-2022 走看看