zoukankan      html  css  js  c++  java
  • H_Dp

    <span style="color:#000099;">/*
    H - 简单dp 例题扩展
    Time Limit:3000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
    Submit
     
    Status
    Description
    A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome. 
    
    As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome. 
    Input
    Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.
    Output
    Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.
    Sample Input
    5
    Ab3bd
    Sample Output
    2
    By Grant Yuan
    2014.7.16
    */
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<cstdlib>
    using namespace std;
    char a[5002];
    char b[5003];
    int dp[2][5003];
    int n;
    int max(int aa,int bb){
      return aa>=bb?aa:bb;
    }
    
    int main()
    {
       while(~scanf("%d",&n)){
         scanf(" %s",&a);
         for(int i=0;i<n;i++)
           b[n-1-i]=a[i];
          
        // puts(a);
        // puts(b);
         memset(dp,0,sizeof(dp));
         int flag=0,flag1=0;
         for(int i=0;i<n;i++)
           for(int j=0;j<n;j++)
           {
               if(a[i]==b[j])/*{flag1=0;
                 if(flag==0)
                    dp[1][j+1]=dp[0][j]+1,flag=1;
                  else
                     dp[0][j+1]=dp[1][j]+1,flag=0;
                     }*/
                     dp[(i+1)&1][j+1]=dp[i&1][j]+1;
                else
                  {/*flag1=1;
                      if(flag==0)
                        dp[1][j+1]=max(dp[0][j+1],dp[1][j]),flag=1;
                      else
                        dp[0][j+1]=max(dp[1][j+1],dp[0][j]),flag=0;*/
                        dp[(i+1)&1][j+1]=max(dp[(i+1)&1][j],dp[i&1][j+1]);
                  }
                  //if(flag1==0)cout<<"相等";
                  //else cout<<"不相等";
                 // cout<<"flag: "<<"i: "<<flag<<" "<<i<<" "<<j<<" "<<dp[flag][j+1]<<endl;
                //  system("pause");
           }
           int l;
           /*if(flag==1)
             l=dp[1][n];
            else
             l=dp[0][n];*/
             l=dp[n&1][n];
           cout<<n-l<<endl;}
           return 0;
    }
    </span>

  • 相关阅读:
    19. 星际争霸之php设计模式--迭代器模式
    18. 星际争霸之php设计模式--观察者模式
    17. 星际争霸之php设计模式--职责链模式
    16. 星际争霸之php设计模式--组合模式
    15. 星际争霸之php设计模式--策略模式
    14. 星际争霸之php设计模式--状态模式
    13. 星际争霸之php设计模式--正面模式
    12. 星际争霸之php设计模式--模板模式
    11. 星际争霸之php设计模式--备忘模式
    10. 星际争霸之php设计模式--原型模式
  • 原文地址:https://www.cnblogs.com/gcczhongduan/p/4065782.html
Copyright © 2011-2022 走看看