zoukankan      html  css  js  c++  java
  • HDOJ 5090 Game with Pearls 二分图匹配


    简单的二分图匹配:

    每个位置可以边到这些数字甚至可以边

    Game with Pearls

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
    Total Submission(s): 122    Accepted Submission(s): 85


    Problem Description
    Tom and Jerry are playing a game with tubes and pearls. The rule of the game is:

    1) Tom and Jerry come up together with a number K. 

    2) Tom provides N tubes. Within each tube, there are several pearls. The number of pearls in each tube is at least 1 and at most N. 

    3) Jerry puts some more pearls into each tube. The number of pearls put into each tube has to be either 0 or a positive multiple of K. After that Jerry organizes these tubes in the order that the first tube has exact one pearl, the 2nd tube has exact 2 pearls, …, the Nth tube has exact N pearls.

    4) If Jerry succeeds, he wins the game, otherwise Tom wins. 

    Write a program to determine who wins the game according to a given N, K and initial number of pearls in each tube. If Tom wins the game, output “Tom”, otherwise, output “Jerry”.
     

    Input
    The first line contains an integer M (M<=500), then M games follow. For each game, the first line contains 2 integers, N and K (1 <= N <= 100, 1 <= K <= N), and the second line contains N integers presenting the number of pearls in each tube.
     

    Output
    For each game, output a line containing either “Tom” or “Jerry”.
     

    Sample Input
    2 5 1 1 2 3 4 5 6 2 1 2 3 4 5 5
     

    Sample Output
    Jerry Tom
     

    Source
     



    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <algorithm>
    
    using namespace std;
    
    const int maxn=110;
    
    int n,K;
    
    struct Edge
    {
        int to,next;
    }edge[maxn*maxn];
    
    int Adj[maxn],Size;
    
    void init()
    {
        memset(Adj,-1,sizeof(Adj)); Size=0;
    }
    
    void add_edge(int u,int v)
    {
        edge[Size].to=v; edge[Size].next=Adj[u]; Adj[u]=Size++;
    }
    
    int linker[maxn];
    bool used[maxn];
    
    bool dfs(int u)
    {
        for(int i=Adj[u];~i;i=edge[i].next)
        {
            int v=edge[i].to;
            if(!used[v])
            {
                used[v]=true;
                if(linker[v]==-1||dfs(linker[v]))
                {
                    linker[v]=u;
                    return true;
                }
            }
        }
        return false;
    }
    
    int hungary()
    {
        int res=0;
        memset(linker,-1,sizeof(linker));
        for(int u=1;u<=n;u++)
        {
            memset(used,false,sizeof(used));
            if(dfs(u)) res++;
        }
        return res;
    }
    
    int a[maxn];
    
    int main()
    {
        int T_T;
        scanf("%d",&T_T);
        while(T_T--)
        {
            scanf("%d%d",&n,&K);
            init();
            for(int i=1;i<=n;i++)
            {
                scanf("%d",a+i);
                for(int j=0;a[i]+j*K<=n;j++)
                {
                    int v=a[i]+j*K;
                    add_edge(i,v);
                }
            }
            int pp=hungary();
            //cout<<"pp: "<<pp<<endl;
            if(pp==n) puts("Jerry");
            else puts("Tom");
        }
        return 0;
    }



    版权声明:来自: 代码代码猿猿AC路 http://blog.csdn.net/ck_boss

  • 相关阅读:
    面向对象第四单元(UML)及期末总结
    面向对象第三单元博客(JML)
    BUAAOO——UNIT2 SUMMARY
    面向对象第一单元总结——格式检查与定性计算
    软件工程-提问回顾与个人总结
    面向对象第三单元总结
    面向对象第二单元总结
    个人博客作业-软件案例分析
    结对项目作业
    软件工程个人项目作业
  • 原文地址:https://www.cnblogs.com/gcczhongduan/p/4806829.html
Copyright © 2011-2022 走看看