zoukankan      html  css  js  c++  java
  • HDU-4432-Sum of divisors ( 2012 Asia Tianjin Regional Contest )

    Sum of divisors

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 4318    Accepted Submission(s): 1382


    Problem Description
    mmm is learning division, she's so proud of herself that she can figure out the sum of all the divisors of numbers no larger than 100 within one day!
    But her teacher said "What if I ask you to give not only the sum but the square-sums of all the divisors of numbers within hexadecimal number 100?

    " mmm get stuck and she's asking for your help.
    Attention, because mmm has misunderstood teacher's words, you have to solve a problem that is a little bit different.
    Here's the problem, given n, you are to calculate the square sums of the digits of all the divisors of n, under the base m.

     

    Input
    Multiple test cases, each test cases is one line with two integers.
    n and m.(n, m would be given in 10-based)
    1≤n≤109
    2≤m≤16
    There are less then 10 test cases.
     

    Output
    Output the answer base m.
     

    Sample Input
    10 2 30 5
     

    Sample Output
    110 112
    Hint
    Use A, B, C...... for 10, 11, 12...... Test case 1: divisors are 1, 2, 5, 10 which means 1, 10, 101, 1010 under base 2, the square sum of digits is 1^2+ (1^2 + 0^2) + (1^2 + 0^2 + 1^2) + .... = 6 = 110 under base 2.
     

    Source
     


    题目:看hint都能看懂啥意思吧。就是去找因数。挺简单~


    AC代码:


    #include<stdio.h>
    #include<iostream>
    #include<algorithm>
    #include<string.h>
    #include<math.h>
    using namespace std;
    
    int bit[100];
    int cnt;
    
    void change(int n,int base)
    {
        cnt=0;
        while(n)
        {
            bit[cnt++]=n%base;
            n/=base;
        }
    }
    int main()
    {
        int n, m;
        while(scanf("%d %d", &n, &m)!=EOF)
        {
            int sum=0;
            int t=(int)sqrt(n*1.0);
            for(int i = 1; i <= t; i++)
            {
                if(n%i == 0)
                {
                    int tmp = i;
                    while(tmp)
                    {
                        sum += ((tmp%m)*(tmp%m));
                        tmp /= m;
                    }
                    tmp = n/i;
                    if(tmp == i)continue;
                    while(tmp)
                    {
                        sum += ((tmp%m) * (tmp%m));
                        tmp /= m;
                    }
                }
            }
            change(sum, m);
            for(int i = cnt-1; i >= 0; i--)
            {
                if(bit[i] > 9) printf("%c", bit[i]-10+'A');
                else printf("%d", bit[i]);
            }
            putchar(10); 
        }
        return 0;
    }



    版权声明:本文博主原创文章,博客,未经同意不得转载。

  • 相关阅读:
    jenkins自动化部署前端项目
    jenkins自动部署java项目
    Jenkins插件修改为国内源
    jenkins搭建以及初始化
    gitlab-ci集成sonarqube完成代码检测
    微信小程序模板消息后端代码
    解决上传图片到服务器 水印文字显示框框不显示文字的问题
    ES transport client使用
    签发的用户认证token超时刷新策略
    api权限管理系统与前后端分离实践
  • 原文地址:https://www.cnblogs.com/gcczhongduan/p/4815974.html
Copyright © 2011-2022 走看看