zoukankan      html  css  js  c++  java
  • poj 2612 Mine Sweeper

    Mine Sweeper
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 6429   Accepted: 2500

    Description

    The game Minesweeper is played on an n by n grid. In this grid are hidden m mines, each at a distinct grid location. The player repeatedly touches grid positions. If a position with a mine is touched, the mine explodes and the player loses. If a positon not containing a mine is touched, an integer between 0 and 8 appears denoting the number of adjacent or diagonally adjacent grid positions that contain a mine. A sequence of moves in a partially played game is illustrated below. 
     
    Here, n is 8, m is 10, blank squares represent the integer 0, raised squares represent unplayed positions, and the figures resembling asterisks represent mines. The leftmost image represents the partially played game. From the first image to the second, the player has played two moves, each time choosing a safe grid position. From the second image to the third, the player is not so lucky; he chooses a position with a mine and therefore loses. The player wins if he continues to make safe moves until only m unplayed positions remain; these must necessarily contain the mines. 

    Your job is to read the information for a partially played game and to print the corresponding board. 

    Input

    The first line of input contains a single postitive integer n <= 10. The next n lines represent the positions of the mines. Each line represents the contents of a row using n characters: a period indicates an unmined positon while an asterisk indicates a mined position. The next n lines are each n characters long: touched positions are denoted by an x, and untouched positions by a period. The sample input corresponds to the middle figure above.

    Output

    Your output should represent the board, with each position filled in appropriately. Positions that have been touched and do not contain a mine should contain an integer between 0 and 8. If a mine has been touched, all positions with a mine should contain an asterisk. All other positions should contain a period.

    Sample Input

    8
    ...**..*
    ......*.
    ....*...
    ........
    ........
    .....*..
    ...**.*.
    .....*..
    xxx.....
    xxxx....
    xxxx....
    xxxxx...
    xxxxx...
    xxxxx...
    xxx.....
    xxxxx...
    

    Sample Output

    001.....
    0013....
    0001....
    00011...
    00001...
    00123...
    001.....
    00123...

    注意:假设踩到地雷。要把全部地雷表示出来。

    #include <iostream>
    using namespace std;
    #define MAX 12
    int n;
    char map[MAX][MAX],ans[MAX][MAX];
    int count(int i,int j,int n){
    	int ans=0;
    	if (map[i-1][j-1]=='*' && i-1>=0 && j-1>=0)
    		ans++;
    	if (map[i-1][j]=='*' && i-1>=0)
    		ans++;
    	if (map[i-1][j+1]=='*' && i-1>=0 && j+1<n)
    		ans++;
    
    	if (map[i][j-1]=='*' && j-1>=0)
    		ans++;	
    	if (map[i][j]=='*')
    		ans++;
    	if (map[i][j+1]=='*' && j+1<n)
    		ans++;
    
    	if (map[i+1][j-1]=='*' && i+1<n && j-1>=0)
    		ans++;
    	if (map[i+1][j]=='*' && i+1<n)
    		ans++;
    	if (map[i+1][j+1]=='*' && i+1<n && j+1<n)
    		ans++;
    	return ans;
    }
    int main(){
    	
    	while (cin>>n){
    		for (int i=0;i<n;i++)
    			for (int j=0;j<n;j++)
    				cin>>map[i][j];
    		int flag=0;
    		for (int i=0;i<n;i++){
    			for (int j=0;j<n;j++){
    				cin>>ans[i][j];
    				if (map[i][j]=='*' && ans[i][j]=='x')
    					flag=1;
    				if (ans[i][j]=='x'){
    					int k=count(i,j,n);
    					ans[i][j]=k+'0';
    				}
    			}
    		}
    		for (int i=0;i<n;i++){
    			for (int j=0;j<n;j++){
    				if (flag==1 && map[i][j]=='*')
    					cout<<map[i][j];
    				else
    					cout<<ans[i][j];
    			}
    			cout<<endl;
    		}
    	}
    	return 0;
    }



  • 相关阅读:
    技术人员的找工之路(1
    技术人员的找工之路(3)
    Endian的由来
    android平台开发笔记1Spinner不能在sub activity中使用
    谈谈Groupon的成功
    线程安全的同步读写类的模板设计
    项目管理文件package.json
    10个每个开发人员都应该知道的强大JavaScript 解构技术
    绿色下载站上线了(MVC +Telerik开源控件)
    我开发的新浪微博应用“微词典”通过审核,欢迎朋友们试用,多多建议!
  • 原文地址:https://www.cnblogs.com/gcczhongduan/p/5197747.html
Copyright © 2011-2022 走看看