zoukankan      html  css  js  c++  java
  • POJ 2309 BST

    BST
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 8565   Accepted: 5202

    Description

    Consider an infinite full binary search tree (see the figure below), the numbers in the nodes are 1, 2, 3, .... In a subtree whose root node is X, we can get the minimum number in this subtree by repeating going down the left node until the last level, and we can also find the maximum number by going down the right node. Now you are given some queries as "What are the minimum and maximum numbers in the subtree whose root node is X?" Please try to find answers for there queries. 

    Input

    In the input, the first line contains an integer N, which represents the number of queries. In the next N lines, each contains a number representing a subtree with root number X (1 <= X <= 231 - 1).

    Output

    There are N lines in total, the i-th of which contains the answer for the i-th query.

    Sample Input

    2
    8
    10
    

    Sample Output

    1 15
    9 11
    

    Source

    POJ Monthly,Minkerui


    lowbit的作用。计算x相应的二进制数中第一个1的位置k,返回权值2k。

    这个函数的作用就是求出t这个数的二进制存储下,最高的非0bit所表示的大小。
    即满足2^k<=t的最大的2^k,当中k为非负整数。


    1、min和max为奇数,否则min和max非叶子,还能够向下拓展

    2、依据满二叉树的性质,x的左右子树的个数都为2的k次方减1个节点

    3、依据二叉树搜索的性质,左子树编号的区间为[min,x-1],右子树的编号区间为[x+1,max]

    由此得出min=x-(2^k-1),max=x+(2^k-1)



    #include <iostream>
    using namespace std;
    int lowbit(int x)
    {
        return x&(-x);
    }
    int main()
    {
        int N;
        cin>>N;
    
        int c;
        for(c=1;c<=N;c++)
        {
            int n;
            cin>>n;
    
            int min,max;
            min=n-lowbit(n)+1;
            max=n+lowbit(n)-1;
    
            cout<<min<<" "<<max<<" "<<endl;
        }
        return 0;
    }
    





  • 相关阅读:
    MySQL基础之排序检索数据
    网络编程之并发网络编程
    网络编程之粘包问题
    MySQL基础之检索数据
    MySQL基础之使用MySQL
    MySQL基础之MySQL简介
    MySQL基础之了解MySQL
    网络编程之socket编程
    网络编程之网络通信原理
    别找了,最全的搜集关键词方法在这里
  • 原文地址:https://www.cnblogs.com/gcczhongduan/p/5275479.html
Copyright © 2011-2022 走看看