zoukankan      html  css  js  c++  java
  • Elven Postman(BST )

    Elven Postman

    Time Limit: 1500/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
    Total Submission(s): 147    Accepted Submission(s): 90


    Problem Description
    Elves are very peculiar creatures. As we all know, they can live for a very long time and their magical prowess are not something to be taken lightly. Also, they live on trees. However, there is something about them you may not know. Although delivering stuffs through magical teleportation is extremely convenient (much like emails). They still sometimes prefer other more “traditional” methods.

    So, as a elven postman, it is crucial to understand how to deliver the mail to the correct room of the tree. The elven tree always branches into no more than two paths upon intersection, either in the east direction or the west. It coincidentally looks awfully like a binary tree we human computer scientist know. Not only that, when numbering the rooms, they always number the room number from the east-most position to the west. For rooms in the east are usually more preferable and more expensive due to they having the privilege to see the sunrise, which matters a lot in elven culture.

    Anyways, the elves usually wrote down all the rooms in a sequence at the root of the tree so that the postman may know how to deliver the mail. The sequence is written as follows, it will go straight to visit the east-most room and write down every room it encountered along the way. After the first room is reached, it will then go to the next unvisited east-most room, writing down every unvisited room on the way as well until all rooms are visited.

    Your task is to determine how to reach a certain room given the sequence written on the root.

    For instance, the sequence 2, 1, 4, 3 would be written on the root of the following tree.

     
    Input
    First you are given an integer T(T10) indicating the number of test cases.

    For each test case, there is a number n(n1000) on a line representing the number of rooms in this tree. n integers representing the sequence written at the root follow, respectively a1,...,an where a1,...,an{1,...,n}.

    On the next line, there is a number q representing the number of mails to be sent. After that, there will be q integers x1,...,xq indicating the destination room number of each mail.
     
    Output
    For each query, output a sequence of move (E or W) the postman needs to make to deliver the mail. For that E means that the postman should move up the eastern branch and W the western one. If the destination is on the root, just output a blank line would suffice.

    Note that for simplicity, we assume the postman always starts from the root regardless of the room he had just visited.
     
    Sample Input
    2 4 2 1 4 3 3 1 2 3 6 6 5 4 3 2 1 1 1
     
    Sample Output
    E WE EEEEE
    模拟了BST的插入。(不加旋转操作方便点)
    #include<bits/stdc++.h>
    #define F first 
    #define S second 
    using namespace std;
    const int M = 1e3 + 10 ;
    pair<int,int> g[M] ;
    int n , x ;
    
    void BST (int u) {
            if (x < u) {
                    if (g[u].F == -1) {
                            g[u].F = x ;
                            return ;
                    }
                    BST (g[u].F) ;
            }
            else {
                    if (g[u].S == -1) {
                            g[u].S = x ;
                            return ;
                    }
                    BST (g[u].S) ;
            }
    }
    
    void dfs (int u) {
            if (x == u) {
                    puts ("") ;
                    return ;
            }
            if (x < u) {
                    printf ("E") ;
                    dfs (g[u].F) ;
            }
            else {
                    printf ("W") ;
                    dfs (g[u].S) ;
            }
    }
    
    int main () {
            int T ;
            scanf ("%d" , &T ) ;
            while (T --) {
                    scanf ("%d" , &n) ;
                    int root ;
                    scanf ("%d" , &root) ;
                    for (int i = 1 ; i <= n ; i ++) g[i] = {-1,-1} ;
                    for (int i = 2 ; i <= n ; i ++) {
                            scanf ("%d" , &x) ;
                            BST (root) ;
                    }
                    int q ;
                    scanf ("%d" , &q) ;
                    while (q --) {
                            scanf("%d" , &x) ;
                            dfs (root) ;
                    }
            }
            return 0 ;
    }
    
  • 相关阅读:
    Spring-12-spring整合Mybatis
    Spring-11-AOP面向切面编程
    jQuery选择器之表单元素选择器
    phpsmarty分配变量
    angular
    ajax 第四步
    ajax第三步
    php+ajax+jq
    二十三种设计模式[4]
    二十三种设计模式[3]
  • 原文地址:https://www.cnblogs.com/get-an-AC-everyday/p/4805613.html
Copyright © 2011-2022 走看看