zoukankan      html  css  js  c++  java
  • [BZOJ] 1089 [SCOI2003]严格n元树

    Time Limit: 1 Sec  Memory Limit: 162 MB
    Submit: 2123  Solved: 1065
    [Submit][Status][Discuss]
    Description
      如果一棵树的所有非叶节点都恰好有n个儿子,那么我们称它为严格n元树。如果该树中最底层的节点深度为d
    (根的深度为0),那么我们称它为一棵深度为d的严格n元树。例如,深度为2的严格2元树有三个,如下图:
    
    
    
      给出n, d,编程数出深度为d的n元树数目。
    
    Input
      仅包含两个整数n, d( 0   <   n   <   =   32,   0  < =   d  < = 16)
    
    Output
      仅包含一个数,即深度为dn元树的数目。
    
    Sample Input
    【样例输入12 2
    
    
    
    【样例输入22 3
    
    
    
    【样例输入33 5
    Sample Output
    【样例输出13
    
    
    
    【样例输出221
    
    
    
    【样例输出258871587162270592645034001
    HINT
    Source

    考虑f[i]表示深度不超过i的严格n元树的个数。
    这样考虑的好处是,如果定义为恰好深度i的个数,那么很难转移,因为它不满,可能有一棵子树使其达到i层,其他不满,就很难受。
    但是定义成这种前缀和形式,就可以转移了,把这种情况全考虑进去,最后差分即可。
    巧妙,叹为观止。

    转移时考虑加一个根,由于是n元树,根下需要n个子树
    f[i]=(f[i-1]^n)+1

    需要高精度(并不能默写。。)
    以及当d=0时,特判答案1。

    #include <iostream>
    #include <string>
    #include <cstring>
    #include <cstdio>
    using namespace std;
    
    const int maxn = 10000;
    
    struct bign{
        int d[maxn], len;
    
        void clean() { while(len > 1 && !d[len-1]) len--; }
    
        bign()          { memset(d, 0, sizeof(d)); len = 1; }
        bign(int num)   { *this = num; } 
        bign(char* num) { *this = num; }
        bign operator = (const char* num){
            memset(d, 0, sizeof(d)); len = strlen(num);
            for(int i = 0; i < len; i++) d[i] = num[len-1-i] - '0';
            clean();
            return *this;
        }
        bign operator = (int num){
            char s[2000]; sprintf(s, "%d", num);
            *this = s;
            return *this;
        }
    
        bign operator + (const bign& b){
            bign c = *this; int i;
            for (i = 0; i < b.len; i++){
                c.d[i] += b.d[i];
                if (c.d[i] > 9) c.d[i]%=10, c.d[i+1]++;
            }
            while (c.d[i] > 9) c.d[i++]%=10, c.d[i]++;
            c.len = max(len, b.len);
            if (c.d[i] && c.len <= i) c.len = i+1;
            return c;
        }
        bign operator - (const bign& b){
            bign c = *this; int i;
            for (i = 0; i < b.len; i++){
                c.d[i] -= b.d[i];
                if (c.d[i] < 0) c.d[i]+=10, c.d[i+1]--;
            }
            while (c.d[i] < 0) c.d[i++]+=10, c.d[i]--;
            c.clean();
            return c;
        }
        bign operator * (const bign& b)const{
            int i, j; bign c; c.len = len + b.len; 
            for(j = 0; j < b.len; j++) for(i = 0; i < len; i++) 
                c.d[i+j] += d[i] * b.d[j];
            for(i = 0; i < c.len-1; i++)
                c.d[i+1] += c.d[i]/10, c.d[i] %= 10;
            c.clean();
            return c;
        }
        bign operator / (const bign& b){
            int i, j;
            bign c = *this, a = 0;
            for (i = len - 1; i >= 0; i--)
            {
                a = a*10 + d[i];
                for (j = 0; j < 10; j++) if (a < b*(j+1)) break;
                c.d[i] = j;
                a = a - b*j;
            }
            c.clean();
            return c;
        }
        bign operator % (const bign& b){
            int i, j;
            bign a = 0;
            for (i = len - 1; i >= 0; i--)
            {
                a = a*10 + d[i];
                for (j = 0; j < 10; j++) if (a < b*(j+1)) break;
                a = a - b*j;
            }
            return a;
        }
        bign operator += (const bign& b){
            *this = *this + b;
            return *this;
        }
    
        bool operator <(const bign& b) const{
            if(len != b.len) return len < b.len;
            for(int i = len-1; i >= 0; i--)
                if(d[i] != b.d[i]) return d[i] < b.d[i];
            return false;
        }
        bool operator >(const bign& b) const{return b < *this;}
        bool operator<=(const bign& b) const{return !(b < *this);}
        bool operator>=(const bign& b) const{return !(*this < b);}
        bool operator!=(const bign& b) const{return b < *this || *this < b;}
        bool operator==(const bign& b) const{return !(b < *this) && !(b > *this);}
    
        string str() const{
            char s[maxn]={};
            for(int i = 0; i < len; i++) s[len-1-i] = d[i]+'0';
            return s;
        }
    };
    
    istream& operator >> (istream& in, bign& x)
    {
        string s;
        in >> s;
        x = s.c_str();
        return in;
    }
    
    ostream& operator << (ostream& out, const bign& x)
    {
        out << x.str();
        return out;
    }
    
    
    bign f[35];
    int n;
    int d;
    
    int main(){
        cin>>n>>d;
        if(n==1&&d==1) return cout<<0,0;
        if(d==0) return cout<<1,0;
        f[1]=1;
        for(int i=1;i<=d;i++) {
            bign tmp=1;
            for(int j=1;j<=n;j++) tmp=tmp*f[i-1];
            f[i]=f[i]+tmp+1;
        }
        bign ans=f[d]-f[d-1];
        cout<<ans;
    }

    本文来自博客园,作者:GhostCai,转载请注明原文链接:https://www.cnblogs.com/ghostcai/p/9247407.html

  • 相关阅读:
    LeetCode OJ--Best Time to Buy and Sell Stock II
    LeetCode OJ--Best Time to Buy and Sell Stock
    路飞学城Python-Day37(practise)
    路飞学城Python-Day37
    路飞学城Python-Day36
    路飞学城Python-Day35
    路飞学城Python-Day35
    “肥宅快乐数”-python暴力版
    路飞学城Python-Day34
    路飞学城Python-Day33
  • 原文地址:https://www.cnblogs.com/ghostcai/p/9247407.html
Copyright © 2011-2022 走看看