zoukankan      html  css  js  c++  java
  • [POJ] 3362 Telephone Lines

    Telephone Lines
    Time Limit: 1000MS      Memory Limit: 65536K
    Total Submissions: 7978     Accepted: 2885
    Description
    
    Farmer John wants to set up a telephone line at his farm. Unfortunately, the phone company is uncooperative, so he needs to pay for some of the cables required to connect his farm to the phone system.
    
    There are N (1 ≤ N ≤ 1,000) forlorn telephone poles conveniently numbered 1..N that are scattered around Farmer John's property; no cables connect any them. A total of P (1 ≤ P ≤ 10,000) pairs of poles can be connected by a cable; the rest are too far apart.
    
    The i-th cable can connect the two distinct poles Ai and Bi, with length Li (1 ≤ Li ≤ 1,000,000) units if used. The input data set never names any {Ai, Bi} pair more than once. Pole 1 is already connected to the phone system, and pole N is at the farm. Poles 1 and N need to be connected by a path of cables; the rest of the poles might be used or might not be used.
    
    As it turns out, the phone company is willing to provide Farmer John with K (0 ≤ K < N) lengths of cable for free. Beyond that he will have to pay a price equal to the length of the longest remaining cable he requires (each pair of poles is connected with a separate cable), or 0 if he does not need any additional cables.
    
    Determine the minimum amount that Farmer John must pay.
    
    Input
    
    * Line 1: Three space-separated integers: N, P, and K
    * Lines 2..P+1: Line i+1 contains the three space-separated integers: Ai, Bi, and Li
    
    Output
    
    * Line 1: A single integer, the minimum amount Farmer John can pay. If it is impossible to connect the farm to the phone company, print -1.
    
    Sample Input
    
    5 7 1
    1 2 5
    3 1 4
    2 4 8
    3 2 3
    5 2 9
    3 4 7
    4 5 6
    Sample Output
    
    4
    Source
    
    USACO 2008 January Silver

    求一条从1到n的路,删去k条最大的边后,剩余的第k-1大边最小
    (可以DAG DP 回头补充)
    考虑二分答案,枚举k-1条边长度,大于的置为1,小于的置为0,跑最短路,检查答案

    #include<iostream>
    #include<queue>
    
    using namespace std;
    
    const int MAXN=20000;
    const int INF=1<<28;
    struct Edge{
        int next,to,w;
    }e[MAXN];
    int ecnt,head[MAXN];
    inline void add(int x,int y,int w){
        e[++ecnt].next = head[x];
        e[ecnt].to = y;
        e[ecnt].w = w;
        head[x]=ecnt;
    }
    
    
    int n,m,st,k;
    int mid;
    
    bool inq[MAXN];
    int dis[MAXN];
    void spfa(){
        queue<int> Q;
        for(int i=1;i<=n;i++) inq[i]=0,dis[i]=INF;
        Q.push(1); inq[1]=1; dis[1]=0;
        while(!Q.empty()){
            int top=Q.front();
            Q.pop() ;inq[top]=0;
            for(int i=head[top];i;i=e[i].next){
                int v=e[i].to ;
                int w=e[i].w > mid;
                if(dis[v]>dis[top]+w){
                    dis[v]=dis[top]+w;
                    if(!inq[v]) Q.push(v); 
                }
            }
        }
    }
    
    int main(){
        cin.sync_with_stdio(false);
        cin.tie(0);
        cin>>n>>m>>k;
        int l=0,r=-INF;
        for(int i=1;i<=m;i++){
            int x,y,w;
            cin>>x>>y>>w;
            add(x,y,w);
            add(y,x,w);
            l=min(l,w);
            r=max(r,w);
        }
        int tmp=++r;
        while(l<r){
            mid=(l+r)>>1;
            spfa();
            if(dis[n]<=k){
                r=mid;
            }else{
                l=mid+1;
            }
        }
        if(l>=tmp){
            cout<<-1<<endl;
            return 0;
        }
        cout<<l<<endl;
        return 0;
    }

    本文来自博客园,作者:GhostCai,转载请注明原文链接:https://www.cnblogs.com/ghostcai/p/9247478.html

  • 相关阅读:
    LeetCode Missing Number (简单题)
    LeetCode Valid Anagram (简单题)
    LeetCode Single Number III (xor)
    LeetCode Best Time to Buy and Sell Stock II (简单题)
    LeetCode Move Zeroes (简单题)
    LeetCode Add Digits (规律题)
    DependencyProperty深入浅出
    SQL Server存储机制二
    WPF自定义RoutedEvent事件示例代码
    ViewModel命令ICommand对象定义
  • 原文地址:https://www.cnblogs.com/ghostcai/p/9247478.html
Copyright © 2011-2022 走看看