zoukankan      html  css  js  c++  java
  • [POJ] 1458 Common Subsequence

    Common Subsequence
    Time Limit: 1000MS      Memory Limit: 10000K
    Total Submissions: 56614        Accepted: 23609
    Description
    
    A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
    Input
    
    The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.
    Output
    
    For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
    Sample Input
    
    abcfbc         abfcab
    programming    contest 
    abcd           mnp
    Sample Output
    
    4
    2
    0
    Source
    
    Southeastern Europe 2003

    LCS问题
    f[i][j]表示S长度为i的前缀和T长度为j的前缀的LCS
    f[i][j]=f[i-1][j-1]+1 (s[i]==t[j])
    f[i][j]=max( f[i-1][j] , f[i][j-1] ) (else)

    //Writer:GhostCai && His Yellow Duck
    
    #include<iostream>
    #include<cstring>
    #define MAXN 500
    using namespace std;
    
    char s[MAXN],t[MAXN]; 
    int lens,lent;
    int f[MAXN][MAXN];
    
    int main(){
        while(cin>>s+1>>t+1){
            memset(f,0,sizeof(f));
            lens=strlen(s+1);
            lent=strlen(t+1);
            for(int i=1;i<=lens;i++){
                for(int j=1;j<=lent;j++){
                    if(s[i]==t[j]){
                        f[i][j]=f[i-1][j-1]+1;
                    }else{
                        f[i][j]=max(f[i-1][j],f[i][j-1]);
                    }
                }
            }
            cout<<f[lens][lent]<<endl;
        }
        return 0;
    }
    

    本文来自博客园,作者:GhostCai,转载请注明原文链接:https://www.cnblogs.com/ghostcai/p/9247508.html

  • 相关阅读:
    通过HTTP发包工具了解HTTP协议
    Oracle之数据库安全
    SQL注入深入剖析
    apache中如何调用CGI脚本
    fastcgi php-cgi与php-fpm区别和之间的关系
    使用PHPExcel实现Excel文件的导入和导出(模板导出)
    学会数据库读写分离、分表分库
    框架Thinkphp5 简单的实现行为 钩子 Hook
    php文件下载
    PHP为JSON数据的API返回空数组或者空对象
  • 原文地址:https://www.cnblogs.com/ghostcai/p/9247508.html
Copyright © 2011-2022 走看看