zoukankan      html  css  js  c++  java
  • poj3262(Protecting the Flowers)贪心

    Description

    Farmer John went to cut some wood and left N (2 ≤ N ≤ 100,000) cows eating the grass, as usual. When he returned, he found to his horror that the cluster of cows was in his garden eating his beautiful flowers. Wanting to minimize the subsequent damage, FJ decided to take immediate action and transport each cow back to its own barn.

    Each cow i is at a location that is Ti minutes (1 ≤ Ti ≤ 2,000,000) away from its own barn. Furthermore, while waiting for transport, she destroysDi (1 ≤ Di ≤ 100) flowers per minute. No matter how hard he tries, FJ can only transport one cow at a time back to her barn. Moving cow i to its barn requires 2 × Ti minutes (Ti to get there and Ti to return). FJ starts at the flower patch, transports the cow to its barn, and then walks back to the flowers, taking no extra time to get to the next cow that needs transport.

    Write a program to determine the order in which FJ should pick up the cows so that the total number of flowers destroyed is minimized.

    Input

    Line 1: A single integer N
    Lines 2.. N+1: Each line contains two space-separated integers, Ti and Di, that describe a single cow's characteristics

    Output

    Line 1: A single integer that is the minimum number of destroyed flowers

    Sample Input

    6
    3 1
    2 5
    2 3
    3 2
    4 1
    1 6

    Sample Output

    86

    Hint

    FJ returns the cows in the following order: 6, 2, 3, 4, 1, 5. While he is transporting cow 6 to the barn, the others destroy 24 flowers; next he will take cow 2, losing 28 more of his beautiful flora. For the cows 3, 4, 1 he loses 16, 12, and 6 flowers respectively. When he picks cow 5 there are no more cows damaging the flowers, so the loss for that cow is zero. The total flowers lost this way is 24 + 28 + 16 + 12 + 6 = 86.

    贪心,考虑两头牛时的情况,牵牛a,b损失分别为2*ta*db和2*tb*da,所以按照ta/da从小到大排序。


    #include <iostream>
    #include <sstream>
    #include <fstream>
    #include <string>
    #include <map>
    #include <vector>
    #include <list>
    #include <set>
    #include <stack>
    #include <queue>
    #include <deque>
    #include <algorithm>
    #include <functional>
    #include <iomanip>
    #include <limits>
    #include <new>
    #include <utility>
    #include <iterator>
    #include <cstdio>
    #include <cstdlib>
    #include <cstring>
    #include <cctype>
    #include <cmath>
    #include <ctime>
    using namespace std;
    typedef long long ll;
    
    ll n, s;
    
    struct cow
    {
        ll t, d;
        bool operator < (const cow& b) const
        {
            return t * b.d < b.t * d;
        }
    };
    
    cow c[100010];
    
    int main()
    {
        cin >> n;
        for (int i = 0; i < n; ++i)
        {
            scanf("%lld%lld", &c[i].t, &c[i].d);
            s += c[i].d;
        }
        sort(c, c+n);
        ll ans = 0;
        for (int i = 0; i < n; ++i)
        {
            ans += 2 * (s - c[i].d) * c[i].t;
            s -= c[i].d;
        }
        cout << ans << endl;
        return 0;
    }
    


  • 相关阅读:
    如何选择硅谷的IT公司
    NSDateFormatter设定日期格式
    内存映射文件
    double 转 int 的精度损失问题
    #ifndef #define 的用法
    How to improve the performance of MB5B
    Vendor Evaluation Questionair弹出空白页
    接受报价后创建合同,却无法弹出相应的合同类型
    SRM税务代码的决定逻辑
    How to improve the performance of MB51
  • 原文地址:https://www.cnblogs.com/godweiyang/p/12203959.html
Copyright © 2011-2022 走看看