zoukankan      html  css  js  c++  java
  • poj1065(Wooden Sticks)

    Description

    There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows: 
    (a) The setup time for the first wooden stick is 1 minute. 
    (b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l <= l' and w <= w'. Otherwise, it will need 1 minute for setup. 
    You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are ( 9 , 4 ) , ( 2 , 5 ) , ( 1 , 2 ) , ( 5 , 3 ) , and ( 4 , 1 ) , then the minimum setup time should be 2 minutes since there is a sequence of pairs ( 4 , 1 ) , ( 5 , 3 ) , ( 9 , 4 ) , ( 1 , 2 ) , ( 2 , 5 ) .

    Input

    The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1 <= n <= 5000 , that represents the number of wooden sticks in the test case, and the second line contains 2n positive integers l1 , w1 , l2 , w2 ,..., ln , wn , each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.

    Output

    The output should contain the minimum setup time in minutes, one per line.

    Sample Input

    3 
    5 
    4 9 5 2 2 1 3 5 1 4 
    3 
    2 2 1 1 2 2 
    3 
    1 3 2 2 3 1 
    

    Sample Output

    2
    1
    3

    有一些木棍,给出每根的长度和重量,依次处理这些木棍,如果当前处理的木棍长度和重量都大于等于前一根木棍,就不需要花时间,否则花费一个单位时间,安排适当的处理顺序,使得总花费最小。解法:贪心思想,首先对木棍排序,按照长度从小到大排序,相同时重量小的在前。用变量flag标记是否已经被处理过。然后依次处理,处理第i根时如果flag=0,那么时间加1,并且遍历之后的木棍,找出最大的上升子序列,也就是全都不需要花费时间的木棍,标记为flag=1即可。

    #include <iostream>
    #include <sstream>
    #include <fstream>
    #include <string>
    #include <map>
    #include <vector>
    #include <list>
    #include <set>
    #include <stack>
    #include <queue>
    #include <deque>
    #include <algorithm>
    #include <functional>
    #include <iomanip>
    #include <limits>
    #include <new>
    #include <utility>
    #include <iterator>
    #include <cstdio>
    #include <cstdlib>
    #include <cstring>
    #include <cctype>
    #include <cmath>
    #include <ctime>
    using namespace std;
    typedef long long LL;
    const int INF = 0x3f3f3f3f;
    const double PI = acos(-1.0);
    const double EPS = 1e-8;
    const int MAXN = 5010;
    int dx[] = {0, 1, 0, -1}, dy[] = {-1, 0, 1, 0};
    
    struct sticks
    {
        int l, w;
        bool flag;
        bool operator < (const sticks& b) const
        {
            if (l == b.l)
                return w < b.w;
            return l < b.l;
        }
    };
    
    sticks st[MAXN];
    
    int main()
    {
        int kase;
        cin >> kase;
        while (kase--)
        {
            int n;
            cin >> n;
            for (int i = 0; i < n; ++i)
            {
                scanf("%d%d", &st[i].l, &st[i].w);
                st[i].flag = false;
            }
            sort(st, st+n);
            int time = 0;
            for (int i = 0; i < n; ++i)
                if (!st[i].flag)
                {
                    time++;
                    st[i].flag = true;
                    int w = st[i].w;
                    for (int j = i+1; j < n; ++j)
                        if (!st[j].flag && st[j].w >= w)
                        {
                            st[j].flag = true;
                            w = st[j].w;
                        }
                }
            cout << time << endl;
        }
        return 0;
    }


  • 相关阅读:
    解决 .net Core 3.1中使用GB2312编码异常
    sql server datetime类型字段使用isnull返回1900-01-01 00:00:00.000的问题
    c# – 从.NET中的字符串获取url参数
    fastjson对象,JSON,字符串,map之间的互转
    Java工具:Java递归去除Json字符串空值(key和value)
    vue运行报错 ‘vue-cli-service‘ 不是内部或外部命令,也不是可运行的程序 或批处理文件。
    java调用CTP API坑【我】
    SpringBoot在logback.xml中读取application.properties中配置的日志路径
    org.apache.ibatis.binding.BindingException: Invalid bound statement (not found): com【我】
    springboot mybatis-plus分页配置不生效【我】
  • 原文地址:https://www.cnblogs.com/godweiyang/p/12203974.html
Copyright © 2011-2022 走看看