zoukankan      html  css  js  c++  java
  • poj3009(Curling 2.0)

    Description

    On Planet MM-21, after their Olympic games this year, curling is getting popular. But the rules are somewhat different from ours. The game is played on an ice game board on which a square mesh is marked. They use only a single stone. The purpose of the game is to lead the stone from the start to the goal with the minimum number of moves.

    Fig. 1 shows an example of a game board. Some squares may be occupied with blocks. There are two special squares namely the start and the goal, which are not occupied with blocks. (These two squares are distinct.) Once the stone begins to move, it will proceed until it hits a block. In order to bring the stone to the goal, you may have to stop the stone by hitting it against a block, and throw again.


    Fig. 1: Example of board (S: start, G: goal)

    The movement of the stone obeys the following rules:

    • At the beginning, the stone stands still at the start square.
    • The movements of the stone are restricted to x and y directions. Diagonal moves are prohibited.
    • When the stone stands still, you can make it moving by throwing it. You may throw it to any direction unless it is blocked immediately(Fig. 2(a)).
    • Once thrown, the stone keeps moving to the same direction until one of the following occurs:
      • The stone hits a block (Fig. 2(b), (c)).
        • The stone stops at the square next to the block it hit.
        • The block disappears.
      • The stone gets out of the board.
        • The game ends in failure.
      • The stone reaches the goal square.
        • The stone stops there and the game ends in success.
    • You cannot throw the stone more than 10 times in a game. If the stone does not reach the goal in 10 moves, the game ends in failure.


    Fig. 2: Stone movements

    Under the rules, we would like to know whether the stone at the start can reach the goal and, if yes, the minimum number of moves required.

    With the initial configuration shown in Fig. 1, 4 moves are required to bring the stone from the start to the goal. The route is shown in Fig. 3(a). Notice when the stone reaches the goal, the board configuration has changed as in Fig. 3(b).


    Fig. 3: The solution for Fig. D-1 and the final board configuration

    Input

    The input is a sequence of datasets. The end of the input is indicated by a line containing two zeros separated by a space. The number of datasets never exceeds 100.

    Each dataset is formatted as follows.

    the width(=w) and the height(=h) of the board
    First row of the board

    ... 
    h-th row of the board

    The width and the height of the board satisfy: 2 <= w <= 20, 1 <= h <= 20.

    Each line consists of w decimal numbers delimited by a space. The number describes the status of the corresponding square.

    0 vacant square
    1 block
    2 start position
    3 goal position

    The dataset for Fig. D-1 is as follows:

    6 6 
    1 0 0 2 1 0 
    1 1 0 0 0 0 
    0 0 0 0 0 3 
    0 0 0 0 0 0 
    1 0 0 0 0 1 
    0 1 1 1 1 1

    Output

    For each dataset, print a line having a decimal integer indicating the minimum number of moves along a route from the start to the goal. If there are no such routes, print -1 instead. Each line should not have any character other than this number.

    Sample Input

    2 1
    3 2
    6 6
    1 0 0 2 1 0
    1 1 0 0 0 0
    0 0 0 0 0 3
    0 0 0 0 0 0
    1 0 0 0 0 1
    0 1 1 1 1 1
    6 1
    1 1 2 1 1 3
    6 1
    1 0 2 1 1 3
    12 1
    2 0 1 1 1 1 1 1 1 1 1 3
    13 1
    2 0 1 1 1 1 1 1 1 1 1 1 3
    0 0

    Sample Output

    1
    4
    -1
    4
    10
    -1

    DFS,注意不能用BFS,因为撞到障碍后障碍会消失,影响到其他状态,所以用DFS,再还原路径,求出所有路径的最小值。因为转弯次数不超过10,所以可以用来剪枝。

    #include <iostream>
    #include <sstream>
    #include <fstream>
    #include <string>
    #include <map>
    #include <vector>
    #include <list>
    #include <set>
    #include <stack>
    #include <queue>
    #include <deque>
    #include <algorithm>
    #include <functional>
    #include <iomanip>
    #include <limits>
    #include <new>
    #include <utility>
    #include <iterator>
    #include <cstdio>
    #include <cstdlib>
    #include <cstring>
    #include <cctype>
    #include <cmath>
    #include <ctime>
    using namespace std;
    const int INF = 0x3f3f3f3f;
    const double PI = acos(-1.0);
    int dx[] = {0, 1, 0, -1}, dy[] = {-1, 0, 1, 0};
    const int maxn = 25;
    
    int h, w;
    int s[maxn][maxn];
    int sx, sy;
    
    bool range(int x, int y)
    {
        return x >= 0 && x < h && y >= 0 && y < w;
    }
    
    int dfs(int x, int y, int cur)
    {
        if (cur > 10)
            return INF;
        int ans = INF;
        for (int i = 0; i < 4; ++i)
        {
            int tmpx = x + dx[i], tmpy = y + dy[i];
            if (!range(tmpx, tmpy) || s[tmpx][tmpy] == 1)
                continue;
            while (range(tmpx, tmpy) && (!s[tmpx][tmpy] || s[tmpx][tmpy] == 3))
            {
                if (s[tmpx][tmpy] == 3)
                    return cur;
                tmpx += dx[i];
                tmpy += dy[i];
            }
            if (!range(tmpx, tmpy))
                continue;
            s[tmpx][tmpy] = 0;
            ans = min(ans, dfs(tmpx-dx[i], tmpy-dy[i], cur+1));
            s[tmpx][tmpy] = 1;
        }
        return ans;
    }
    
    int main()
    {
        while (cin >> w >> h && (w || h))
        {
            for (int i = 0; i < h; ++i)
                for (int j = 0; j < w; ++j)
                {
                    scanf("%d", &s[i][j]);
                    if (s[i][j] == 2)
                    {
                        s[i][j] = 0;
                        sx = i;
                        sy = j;
                    }
                }
            int ans = dfs(sx, sy, 1);
            if (ans == INF)
                ans = -1;
            cout << ans << endl;
        }
        return 0;
    }


  • 相关阅读:
    Gym
    HDU-2680 Choose the best route 单向边+反向dijkstra
    Hdu1010Tempter of the Bone 深搜+剪枝
    CodeForces
    CodeForces
    Gym-101375C MaratonIME eats japanese food 初始化struct技巧
    Gym
    java was started but returned exit code =-805306369的处理方法
    启动myeclipse弹窗Please allow Subclipse team to receive anonymous usage statistics for this Eclipse intance
    eclipse包分层
  • 原文地址:https://www.cnblogs.com/godweiyang/p/12203990.html
Copyright © 2011-2022 走看看