zoukankan      html  css  js  c++  java
  • ACM hdu 1019 Least Common Multiple

    Problem Description
    The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

     

    Input
    Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.
     

    Output
    For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.
     

    Sample Input
    2 3 5 7 15 6 4 10296 936 1287 792 1
     

    Sample Output
    105 10296
    /***********************

    简单数学题,求连续n个数的最小公倍数

    **************************/

    Code:

    #include <iostream>
    #include<string.h>
    using namespace std;
    int a[10000];
    int gcd(int a,int b)//求最大公约数
    {
        int temp;
        if(a<b)
        {
            temp = a;a = b;b = temp;
        }
        return (b==0)?a:gcd(b,a%b);
    }
    int LCM(int a,int b)//求最小公倍数
    {
        return a/gcd(a,b)*b; //开始写成 a*b/gcd(a,b),WA了两次,因为可能会溢出
    }
    int main()
    {
        int T,n,ans,x;
        cin>>T;
        while(T--)
        {
            //memset(a,0,sizeof(a));
            ans = 1;
            cin>>n>>x;
            ans = LCM(ans,x);
            for(int i = 0;i<n-1;i++)
            {
                cin>>x;
                ans = LCM(ans,x);
            }
            cout<<ans<<endl;
        }
    
        return 0;
    }
    




  • 相关阅读:
    数据库设计
    Java各类格式转换
    Linux下如何查看tomcat是否启动/系统日志等
    string去空格
    Tomcat
    linux下的显示有中国农历的日历ccal
    Linux命令
    JSP学习-02隐式对象
    jQuery 遍历
    jQuery 隐藏效果
  • 原文地址:https://www.cnblogs.com/gray1566/p/3704317.html
Copyright © 2011-2022 走看看