zoukankan      html  css  js  c++  java
  • 1024. Palindromic Number (25)

    A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

    Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

    Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

    Input Specification:

    Each input file contains one test case. Each case consists of two positive numbers N and K, where N (<= 1010) is the initial numer and K (<= 100) is the maximum number of steps. The numbers are separated by a space.

    Output Specification:

    For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.

    Sample Input 1:

    67 3
    

    Sample Output 1:

    484
    2
    

    Sample Input 2:

    69 3
    

    Sample Output 2:

    1353
    3
    

     题目大意:求一个数是否是回文数,如果不是,则将与其反转数相加后,再次判断是否是回文数,以此类推。

     解题:好几次没把握住数据长度,int-long-long long发现都不够,最后只能用字符型!无奈脸,从题目中推出10^10,进行100次叠加,数据可能是10^20,超过long long 的10^19;

    #include<iostream>
    #include<cstring>
    #include<cstdio>
    #include<algorithm>
    using namespace std;
    string add(string s,string rev){
    	string s1;
    	int length = s.size();
    	int i;
    	int index = 0;
    	int sum;
    	for(i=length-1;i>=0;i--){
    		sum = s[i] + rev[i] - '0' - '0' +index;
    		s1.insert(s1.begin(),sum%10+'0');
    		index = sum/10;
    	}
    	if(index){
    		s1.insert(s1.begin(),index+'0');
    	}
    	return s1;
    }
    int palindromic(string& s,string& rev){
    	rev = s;
    	reverse(rev.begin(),rev.end());
    	if(s == rev){
    		return true;
    	}
    	s = add(s,rev);
    	return false;
    }
    int main(){
    	string s,rev;
    	int k;
    	cin>>s>>k;
    	int i=0;
    	while(i < k){
    		if(palindromic(s,rev)){
    			break;
    		}
    		i++;
    	}
    	cout<<s<<endl<<i<<endl;
    	return 0;
    }
    

      

  • 相关阅读:
    记php多张图片合成一张图片 压缩固定分辨率 合并生成竖列 纵向长图(可用于商品详情图合并下载)
    记php-mysql分页查询出现重复数据
    记laravel order by 问题
    记登录注册时候 前端js明文密码 加密传输 php解密
    记下载oss图片接口(附带删除)
    记tp5.1使用composer PhpOffice的xlsx表格文件导入数据库
    记php移动并压缩多级目录文件为zip文件并上传oss
    Jmeter服务器性能监控工具插件之ServerAgent
    Jmeter阶梯式加压测试
    Jmeter 下载+安装+汉化+版本更新+备份使用(Jmeter 4+版本均适用)
  • 原文地址:https://www.cnblogs.com/grglym/p/7665877.html
Copyright © 2011-2022 走看看