zoukankan      html  css  js  c++  java
  • 1094. The Largest Generation (25)

    A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.

    Input Specification:

    Each input file contains one test case. Each case starts with two positive integers N (<100) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M (<N) which is the number of family members who have children. Then M lines follow, each contains the information of a family member in the following format:

    ID K ID[1] ID[2] ... ID[K]

    where ID is a two-digit number representing a family member, K (>0) is the number of his/her children, followed by a sequence of two-digit ID's of his/her children. For the sake of simplicity, let us fix the root ID to be 01. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.

    Sample Input:

    23 13
    21 1 23
    01 4 03 02 04 05
    03 3 06 07 08
    06 2 12 13
    13 1 21
    08 2 15 16
    02 2 09 10
    11 2 19 20
    17 1 22
    05 1 11
    07 1 14
    09 1 17
    10 1 18
    

    Sample Output:

    9 4

    #include<iostream>
    #include<vector>
    #include<queue>
    #include<cstdio>
    using namespace std;
    int main(){
    	vector<int>vt[102];
    	int n,m;
    	scanf("%d%d",&n,&m);
    	int i,j;
    	int id,k;
    	int val;
    	for(i=0;i<m;i++){
    		scanf("%d%d",&id,&k);
    		for(j=0;j<k;j++){
    			scanf("%d",&val);
    			vt[id].push_back(val);
    		}
    	}
    	queue<int>q;
    	q.push(1);
    	int level=1;
    	int lev=1;
    	int largestnum=1;
    	int cnt=0;
    	int last=1,start=0;
    	while(!q.empty()){
    		int tmp=q.front();
    		q.pop();
    		start++;
    		int size=vt[tmp].size();
    		for(i=0;i<size;i++){
    			q.push(vt[tmp][i]);
    			cnt++;
    		}
    		if(start==last){
    			lev++;
    			start=0;
    			if(cnt>largestnum){
    				largestnum=cnt;
    				level=lev;
    			}
    			last=q.size();
    			cnt=0;
    			//cout<<cnt<<" "<<start<<" "<<last<<endl;
    		}
    	}
    	printf("%d %d",largestnum,level);
    	return 0; 
    } 
    

      



  • 相关阅读:
    数据库分页
    SpringBoot 集成 MQTT
    mybatis的级联查询-懒加载遇到的序列化问题
    springboot学习:第二天
    SpringSecurity学习
    大日志文件查看方式
    logger(七)、springBoot的日志源码查看(LogBack + slf4j)——配置的实际工作类Action
    logger(六)、springBoot的日志源码查看(LogBack + slf4j)—— ContextInitializer
    logger(五)、springBoot的日志源码查看(LogBack + slf4j)——Appender
    logger(四)、springBoot的日志源码查看(LogBack + slf4j)——记录日志
  • 原文地址:https://www.cnblogs.com/grglym/p/8001097.html
Copyright © 2011-2022 走看看