zoukankan      html  css  js  c++  java
  • 路由重分布(二)

    实验要求:使用路由重分布让路由器获得所有路由条目

    拓扑如下:

     

    配置如下:

    R1
    enable
    configure terminal
    interface s0/0/0
    ip address 192.168.4.2 255.255.255.0
    no shutdown
    interface s0/1/0
    ip address 192.168.1.1 255.255.255.0
    no shutdown
    interface s0/0/1
    ip address 192.168.2.1 255.255.255.0
    no shutdown
    exit
    ip route 192.168.7.0 255.255.255.0 192.168.4.1
    router ospf 1
    network 192.168.1.0 0.0.0.255 area 0
    network 192.168.2.0 0.0.0.255 area 0
    redistribute static subnet
    redistribute connected subnet


    R2
    enable
    configure terminal
    interface s0/1/0
    ip address 192.168.1.2 255.255.255.0
    no shutdown
    clock rate 64000
    interface s0/0/1
    ip address 192.168.6.2 255.255.255.0
    no shutdown
    clock rate 64000
    interface s0/0/0
    ip address 192.168.3.1 255.255.255.0
    no shutdown
    exit
    router ospf 1
    network 192.168.1.0 0.0.0.255 area 0
    network 192.168.3.0 0.0.0.255 area 0
    redistribute rip metric 1
    exit
    router rip
    version 2
    network 192.168.6.0
    redistribute ospf 1 metric 1

    R3
    enable
    configure terminal
    interface s0/0/0
    ip address 192.168.2.2 255.255.255.0
    clock rate 64000
    no shutdown
    interface s0/0/1
    ip address 192.168.3.2 255.255.255.0
    clock rate 64000
    no shutdown
    interface s0/1/0
    ip address 192.168.5.1 255.255.255.0
    clock rate 64000
    no shutdown
    exit
    router ospf 1
    network 192.168.2.0 0.0.0.255 area 0
    network 192.168.3.0 0.0.0.255 area 0
    redistribute eigrp 1 metric 1 metric-type 1 subnet
    exit
    router eigrp 1
    network 192.168.5.0 0.0.0.255
    redistribute ospf 1 metric 1000 100 255 1 1500


    R4
    enable
    configure terminal
    interface f0/0
    ip address 192.168.7.254 255.255.255.0
    no shutdown
    interface s0/0/0
    ip address 192.168.4.1 255.255.255.0
    clock rate 64000
    no shutdown
    exit
    ip route 0.0.0.0 0.0.0.0 192.168.4.2

    R5
    enable
    configure terminal
    interface s0/0/0
    ip address 192.168.6.1 255.255.255.0
    no shutdown
    interface f0/0
    ip address 192.168.9.254 255.255.255.0
    no shutdown
    exit
    route rip
    version 2
    network 192.168.9.0
    network 192.168.6.0


    R6
    enable
    configure terminal
    interface s0/0/0
    ip address 192.168.5.2 255.255.255.0
    no shutdown
    interface f0/0
    ip address 192.168.8.254 255.255.255.0
    no shutdown
    exit
    route eigrp 1
    network 192.168.5.0 0.0.0.255
    network 192.168.8.0 0.0.0.255

  • 相关阅读:
    Git的简单使用
    git中查看全部分支的命令
    ModuleNotFoundError: No module named '__main__.base'; '__main__' is not a package(即 if __name__=='__main__'的深入理解)
    django中使用filter()(即对QuerySet操作)时踩的坑
    django模型中如何创建数据并保存到数据库
    django中使用mysql创建索引时报错MySQL does not support a database index on longtext columns
    python环境的编码
    synchronized关键字以及实例锁 类锁
    深拷贝与浅拷贝
    java String不可变对象,但StringBuffer是可变对象
  • 原文地址:https://www.cnblogs.com/guoshiyu/p/9215202.html
Copyright © 2011-2022 走看看