zoukankan      html  css  js  c++  java
  • 神州数码OSPF基于端口认证(简单认证、MD5认证)

    实验要求:掌握OSPF基于端口认证方式

    拓扑如下

    简单认证

    R1

    enable  进入特权模式

    config   进入全局模式

    hostname R1  修改名称

    interface s0/1  进入端口

    ip aadress 192.168.1.1 255.255.255.0  设置IP地址

    physical-layer speed 64000  设置同步时钟

    interface l0  进入端口

    ip address 192.168.2.254 255.255.255.0  设置IP地址

    exit   返回上一级

    router ospf 1  启动OSPF协议

    network 192.168.1.0 255.255.255.0 area 0  添加直连网段到OSPF

    network 192.168.2.0 255.255.255.0 area 0  添加直连网段到OSPF

    interface s0/1  进入端口

    ip ospf authentication simple  启动OSPF端口简单认证

     ip ospf password 978285   设置简单认证密码

    R2

    enable  进入特权模式

    config   进入全局模式

    hostname R1  修改名称

    interface s0/1  进入端口

    ip aadress 192.168.1.2 255.255.255.0  设置IP地址

    physical-layer speed 64000  设置同步时钟

    interface l0  进入端口

    ip address 192.168.3.254 255.255.255.0  设置IP地址

    exit   返回上一级

    router ospf 1  启动OSPF协议

    network 192.168.1.0 255.255.255.0 area 0  添加直连网段到OSPF

    network 192.168.3.0 255.255.255.0 area 0  添加直连网段到OSPF

    interface s0/1  进入端口

    ip ospf authentication simple  启动OSPF端口简单认证

    ip ospf password 978285   设置简单认证密码

    MD5认证

    R1

    enable  进入特权模式

    config   进入全局模式

    hostname R1  修改名称

    interface s0/1  进入端口

    ip aadress 192.168.1.1 255.255.255.0  设置IP地址

    physical-layer speed 64000  设置同步时钟

    interface l0  进入端口

    ip address 192.168.2.254 255.255.255.0  设置IP地址

    exit   返回上一级

    router ospf 1  启动OSPF协议

    network 192.168.1.0 255.255.255.0 area 0  添加直连网段到OSPF

    network 192.168.2.0 255.255.255.0 area 0  添加直连网段到OSPF

    interface s0/1  进入端口

    ip ospf authentication message-digest       启动OSPF端口MD5认证

     ip ospf message-digest-key 1 md5 978285   设置MD5认证密码

    R2

    enable  进入特权模式

    config   进入全局模式

    hostname R1  修改名称

    interface s0/1  进入端口

    ip aadress 192.168.1.1 255.255.255.0  设置IP地址

    physical-layer speed 64000  设置同步时钟

    interface l0  进入端口

    ip address 192.168.3.254 255.255.255.0  设置IP地址

    exit   返回上一级

    router ospf 1  启动OSPF协议

    network 192.168.1.0 255.255.255.0 area 0  添加直连网段到OSPF

    network 192.168.3.0 255.255.255.0 area 0  添加直连网段到OSPF

    interface s0/1  进入端口

    ip ospf authentication message-digest      启动OSPF端口MD5认证

    ip ospf message-digest-key 1 md5 978285   设置MD5认证密码

    相关命令

    基于端口的简单认证

    ip ospf authentication simple 在相应端口启动简单认证

    ip ospf password [密码] 在相应端口设置认证密码

     

    基于端口的MD5认证

    ip ospf authentication message-digest 在相应端口启动认证

    ip ospf message-digest-key [keyID] md5 [密码] 在相应端口设置keyID以及认证密码

  • 相关阅读:
    [array] leetcode
    [array] leetCode-27. Remove Element
    [array] leetCode-26. Remove Duplicates from Sorted Array
    [array] leetCode-18. 4Sum -Medium
    [array] leetCode-15. 3Sum-Medium
    [array] leetCode-16. 3Sum Closest -Medium
    [array] leetCode-11. Container With Most Water-Medium
    [array] leetCode-4-Median of Two Sorted Arrays-Hard
    [array] leetCode-1-Two Sum-Easy
    【读书笔记与思考】Andrew 机器学习课程笔记
  • 原文地址:https://www.cnblogs.com/guoshiyu/p/9323482.html
Copyright © 2011-2022 走看看