zoukankan      html  css  js  c++  java
  • 走楼梯2

    Description

     One steps through integer points of the straight line. The length of a step must be nonnegative and can be by one bigger than, equal to, or by one smaller than the length of the previous step.
     What is the minimum number of steps in order to get from x to y? The length of the first and the last step must be 1.
     Input consists of a line containing n, the number of test cases. For each test case, a line follows with two integers: 0 <= x <= y < 2^31. For each test case, print a line giving the minimum number of steps to get from x to y.

    Sample Input

    3
    45 48
    45 49
    45 50

    Sample Output

    3
    3
    4

    题解

      设d为两点之间的距离,理想情况下,我们总是希望每一步的步数总是比上一步增加,但是由于最后的一步是1,所以不可能是一直上升,那么理想情况下,我们的步数的组成应该是(123...nn...321),满足(d=(1+2+3+...+n)*2),那么此时总步数达到最小,为2n。
      下面考虑不理想情况,也就是((1+2+3+...n)*2<d),记(d_r=d-(1+2+3+...+n)*2)
    第一种情况
      (d_r>n),设(d_r=n+k=(n+1)+(k-1)),其中(k>0)
    那么步数的组成可以为(123...n(n+1)n...(n-k)(n-k)...321),由于步数单调递增的,所以总步数也是最小的,为2n+2。
    第二种情况
      (d_r<=n),那么步数的组成可以为(123...nn...d_rd_r...321),由于步数单调递增的,所以总步数也是最小的,为2n+1。
    AC代码

    #include <iostream>
    using namespace std;
    int main()
    {
        int begin,end,d,steps,n;
        cin>>n;
        while(n--)
        {
            cin >> begin >> end;
            d = end - begin;
            steps = 0;
            int i = 1;
            while(d >= 2 * i)
            {
                d -= 2*i;
                steps += 2;
                ++i;
            }
            if(d > i)
                steps += 2;
            else if(d > 0)
                ++steps;
            cout << steps << endl;
        }
        return 0;
    }
    
  • 相关阅读:
    自动化测试最新面试题和答案
    没有接口设计文档怎么做测试?
    测试岗/测试开发岗面经合集
    安卓测试常用的 ADB 命令
    面试问题集合
    springboot测试邮件发送
    swagger
    shiro 登录拦截和用户认证、资源授权
    SpringSecurity(安全框架)
    SpringBoot整合Mybatis框架
  • 原文地址:https://www.cnblogs.com/h-hg/p/8593192.html
Copyright © 2011-2022 走看看