zoukankan      html  css  js  c++  java
  • 1002 A+B for Polynomials (25分)

    This time, you are supposed to find A+B where A and B are two polynomials.

    Input Specification:

    Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

    N1​​ aN1​​​​ N2​​ aN2​​​​ ... NK​​ aNK​​​​

    where K is the number of nonzero terms in the polynomial, Ni​​ and aNi​​​​ (,) are the exponents and coefficients, respectively. It is given that 1,0.

    Output Specification:

    For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

    Sample Input:

    2 1 2.4 0 3.2
    2 2 1.5 1 0.5
    
     

    Sample Output:

    3 2 1.5 1 2.9 0 3.2

    题解:用C++写了两次只通过了部分数据额,最后看别人的博客是用C语言来写的,确实,用C++来控制输入输出的格式不太好控制。

    #include<iostream>
    
    using namespace std;
    
    int main() {
        float a[1001] = {0};
        int k;
        int exp;
        float coe;
    
        cin >> k;
        for(int i = 0; i < k; ++i) {
            cin >> exp >> coe;
            a[exp] += coe;
        }
    
        cin >> k;
        for(int i = 0; i < k; ++i) {
            cin >> exp >> coe;
            a[exp] += coe;
        }
    
        int count = 0;
        for (int i = 0; i < 1001; ++i) {
            if (a[i] != 0) count++;
        }
    
        cout << count;
        for (int i = 1000; i >= 0; --i) {
            if (a[i] > 0)
                cout << " " << i << " " << a[i];
        }
    
    }
    

      


    2021-01-28

    Python列表表达式:[ expression for i in iterable ]

    poly = [0 for _ in range(1001)]

    按照习惯,有时候单个独立下划线是用作一个名字,来表示某个变量是临时的或无关紧要的。

    例如,在下面的循环中,我们不需要访问正在运行的索引,我们可以使用“_”来表示它只是一个临时值

    poly = [0 for _ in range(1001)]
    
    
    def add():
        global poly
        line = input().split()[1:]
        i = 0
        while i < len(line) - 1:
            poly[int(line[i])] += float(line[i + 1])
            i += 2
    
    
    add()
    add()
    
    count = 0
    for i in range(1000, -1, -1):
        if poly[i] != 0:
            count += 1
    
    print(count, end='')
    for i in range(1000, -1, -1):
        if poly[i] != 0:
            print(" %d %.1f" % (i, poly[i]), end='')
    永远渴望,大智若愚(stay hungry, stay foolish)
  • 相关阅读:
    时序数据库入门
    MySQL执行计划extra中的using index 和 using where using index 的区别
    ETL的详细解释定义
    六种 主流ETL 工具的比较(DataPipeline,Kettle,Talend,Informatica,Datax ,Oracle Goldengate)
    使用 IntraWeb (37)
    使用 IntraWeb (36)
    使用 IntraWeb (35)
    使用 IntraWeb (34)
    使用 IntraWeb (33)
    使用 IntraWeb (32)
  • 原文地址:https://www.cnblogs.com/h-hkai/p/12104814.html
Copyright © 2011-2022 走看看