zoukankan      html  css  js  c++  java
  • 1007 Maximum Subsequence Sum

    Given a sequence of K integers { N​1​​, N​2​​, ..., N​K​​ }. A continuous subsequence is defined to be { N​i​​, N​i+1​​, ..., N​j​​ } where 1. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

    Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

    Input Specification:

    Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤). The second line contains K numbers, separated by a space.

    Output Specification:

    For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

    Sample Input:

    10
    -10 1 2 3 4 -5 -23 3 7 -21
    
     

    Sample Output:

    10 1 4

    题意:

    最大子序列和

    Code:

    #include<iostream>
    #include<algorithm>
    #include<vector>
    
    using namespace std;
    
    int main() {
        int n;
        cin >> n;
    
        vector<int> arr;
        for (int i = 0; i < n; ++i) {
            int num;
            cin >> num;
            arr.push_back(num);
        }
    
        int sum = -1, left = 0, right = n - 1;
        int temp = 0, tempLeft = 0;
        for (int i = 0; i < n; ++i) {
            temp += arr[i];
            if (temp < 0) {
                temp = 0;
                tempLeft = i + 1;
            } else if (temp > sum) {
                sum = temp;
                left = tempLeft;
                right = i;
            }
        }
    
        if (sum < 0) sum = 0;
        cout << sum << " " << arr[left] << " " << arr[right];
    
        return 0;
    }
    

      

    参考:

    https://www.liuchuo.net/archives/2122

    永远渴望,大智若愚(stay hungry, stay foolish)
  • 相关阅读:
    JavaScript Date对象和函数 (一)
    Css3 文字渐变整理(一)
    Asp.net Core CacheHelper 通用缓存帮助类
    .net core中使用GB2312编码的问题
    苹果手机微信浏览器select标签选择完成之后页面不会自动回到原位
    .Net Core NOPI操作word(二) 表格操作
    .Net Core NOPI操作word(一)
    .NetCore中EFCore的使用整理(三)-关联表操作
    windos server2012安装.net core 2.2问题
    C# 最简单的使程序单进程运行的方法
  • 原文地址:https://www.cnblogs.com/h-hkai/p/12575313.html
Copyright © 2011-2022 走看看