zoukankan      html  css  js  c++  java
  • 1012 The Best Rank

    To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

    For example, The grades of CME and A - Average of 4 students are given as the following:

    StudentID  C  M  E  A
    310101     98 85 88 90
    310102     70 95 88 84
    310103     82 87 94 88
    310104     91 91 91 91
    
     

    Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

    Input Specification:

    Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of CM and E. Then there are M lines, each containing a student ID.

    Output Specification:

    For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

    The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

    If a student is not on the grading list, simply output N/A.

    Sample Input:

    5 6
    310101 98 85 88
    310102 70 95 88
    310103 82 87 94
    310104 91 91 91
    310105 85 90 90
    310101
    310102
    310103
    310104
    310105
    999999
    
     

    Sample Output:

    1 C
    1 M
    1 E
    1 A
    3 A
    N/A

    题意:

    给出几个学生的成绩输出所求学生成绩的最高排名,有几门成绩排名相等,则按照A C M E 顺序输出。

    Code:

    #include<iostream>
    #include<algorithm>
    #include<string>
    #include<vector>
    #include<map>
    
    using namespace std;
    
    typedef struct Student {
        string num;
        int C;
        int M;
        int E;
        int A;
        int rankOfC;
        int rankOfM;
        int rankOfE;
        int rankOfA;
        vector<pair<char, int>> inRank;
    }student;
    
    vector<student> s;
    
    bool CmpOfC(student x, student y) {
        return x.C > y.C;
    }
    
    bool CmpOfM(student x, student y) {
        return x.M > y.M;
    }
    
    bool CmpOfE(student x, student y) {
        return x.E > y.E;
    }
    
    bool CmpOfA(student x, student y) {
        return x.A > y.A;
    }
    
    bool CmpOfInRank(pair<char, int> x, pair<char, int> y) {
        if (x.second == y.second) {
            if (x.first == 'E' && y.first == 'M' ||
                x.first == 'M' && y.first == 'E')
                return x.first > y.first;
            else 
                return x.first < y.first;
        } else {
            return x.second < y.second;
        }
    }
    
    int main() {
        int n, m;
        cin >> n >> m;
    
        for (int i = 0; i < n; ++i) {
            string id;
            int c, m, e, a;
            cin >> id >> c >> m >> e;
            a = (c + m + e) / 3;
            student S = {id, c, m, e, a};
            s.push_back(S);
        }
    
        sort(s.begin(), s.end(), CmpOfC);
        for (int i = 0; i < s.size(); ++i) {
            s[i].rankOfC = i + 1;
            s[i].inRank.push_back({'C', i+1});
        }
    
        sort(s.begin(), s.end(), CmpOfM);
        for (int i = 0; i < s.size(); ++i) {
            s[i].rankOfM = i + 1;
            s[i].inRank.push_back({'M', i+1});
        }
    
        sort(s.begin(), s.end(), CmpOfE);
        for (int i = 0; i < s.size(); ++i) {
            s[i].rankOfE = i + 1;
            s[i].inRank.push_back({'E', i+1});
        }
    
        sort(s.begin(), s.end(), CmpOfA);
        for (int i = 0; i < s.size(); ++i) {
            s[i].rankOfA = i + 1;
            s[i].inRank.push_back({'A', i+1});
        }
    
        map<string, student> M;
    
        for (int i = 0; i < s.size(); ++i) {
            M.insert({s[i].num, s[i]});
        }
    
        for (int i = 0; i < m; ++i) {
            string id;
            cin >> id;
            if (M.find(id) != M.end()) {
                sort(M.find(id)->second.inRank.begin(), M.find(id)->second.inRank.end(), CmpOfInRank);
                cout << M.find(id)->second.inRank[0].second << " " << M.find(id)->second.inRank[0].first << endl;
            } else {
                cout << "N/A" << endl;
            }
        }
    
        return 0;
    }
    

      

    一组数据没有通过。

    永远渴望,大智若愚(stay hungry, stay foolish)
  • 相关阅读:
    经典业务: 删除最老的文件
    The LIVE555TM HLS Proxy
    OpenGL
    OpenCV
    STUN, TURN, and ICE
    【AI学习总结】均方误差(Mean Square Error,MSE)与交叉熵(Cross Entropy,CE)损失函数
    SpringCloud中一些基本配置
    Redmibook笔记本触摸板失灵
    对称加密
    Java数字签名工具类
  • 原文地址:https://www.cnblogs.com/h-hkai/p/12587754.html
Copyright © 2011-2022 走看看