zoukankan      html  css  js  c++  java
  • 1014 Waiting in Line

    Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:

    • The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the N lines are full, all the customers after (and including) the (st one will have to wait in a line behind the yellow line.
    • Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
    • Customer​i​​ will take T​i​​ minutes to have his/her transaction processed.
    • The first N customers are assumed to be served at 8:00am.

    Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.

    For example, suppose that a bank has 2 windows and each window may have 2 customers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, customer​1​​ is served at window​1​​ while customer​2​​ is served at window​2​​. Customer​3​​ will wait in front of window​1​​ and customer​4​​ will wait in front of window​2​​. Customer​5​​ will wait behind the yellow line.

    At 08:01, customer​1​​ is done and customer​5​​ enters the line in front of window​1​​ since that line seems shorter now. Customer​2​​ will leave at 08:02, customer​4​​ at 08:06, customer​3​​ at 08:07, and finally customer​5​​ at 08:10.

    Input Specification:

    Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (≤, number of windows), M (≤, the maximum capacity of each line inside the yellow line), K (≤, number of customers), and Q (≤, number of customer queries).

    The next line contains K positive integers, which are the processing time of the K customers.

    The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.

    Output Specification:

    For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output Sorry instead.

    Sample Input:

    2 2 7 5
    1 2 6 4 3 534 2
    3 4 5 6 7
    
     

    Sample Output:

    08:07
    08:06
    08:10
    17:00
    Sorry

    题意:

    N个窗口每个窗口最多容纳M个人排队,余下的人在大厅等候,当一个customer办理完成之后,等候的人到有空位的窗口去办理业务,如果同时有两个空位,则到编号小的空位去。做这道题的时候让我想到了,操作系统中的作业调度,这种情况符合先来先服务(FIFO)的原则。自然想到用队列来解决问题。要是有更多的测试数据就好了。

    Code:

    #include<iostream>
    #include<vector>
    #include<queue>
    #include<map>
    #include<iomanip>
    #include<climits>
    
    using namespace std;
    
    typedef struct Customer {
        int num;
        int startTime;
        int doneTime;
    }cus;
    
    int main() {
        int N, M, K, Q;
        cin >> N >> M >> K >> Q;
    
        vector<queue<cus>> v(N);
        vector<int> time(N, 0);
        map<int, cus> m;
    
        int i, t, j = 1, flag = 0;
        for (i = 0; i < N*M; ++i) {
            cin >> t;
            v[i%N].push({i+1, time[i%N], time[i%N]+t});
            m.insert({i+1, {i+1, time[i%N], time[i%N]+t}});
            time[i%N] += t;
        }
        for (; i < K; ++i) {
            cin >> t;
            flag = 0;
    
            int endTime = INT_MAX, tag;
            for (int k = 0; k < N; ++k) {
                if (v[k].size() < M && v[k].front().doneTime < endTime) {
                    tag = k;
                    flag = 1;
                }
            }
    
            if (flag) {
                v[tag].push({i+1, time[tag], time[tag]+t});
                m.insert({i+1,{i+1, time[tag], time[tag]+t}});
                time[tag] += t;
                continue;
            }
    
            for (; j < 541; ++j) {
                for (int k = 0; k < N; ++k) {
                    if (v[k].front().doneTime == j) {
                        v[k].pop();
                        v[k].push({i+1, time[k], time[k]+t});
                        m.insert({i+1,{i+1, time[k], time[k]+t}});
                        time[k] += t;
                        flag = 1;
                    }
                }
                if (flag) { --j; break; }
            }
        }
    
        for (int i = 0; i < Q; ++i) {
            cin >> t;
            int mins, hours;
            mins = m[t].doneTime % 60;
            hours = m[t].doneTime / 60;
            if (m[t].startTime >= 540) cout << "Sorry" << endl;
            else cout << setfill('0') << setw(2) << 8+hours << ":" << setfill('0') << setw(2) << mins << endl;
        }
    
        return 0;
    }
    

      

      

    搞了半天就过了一组数据,挺失落的。


     看了一下别人的博客,发现只要开始时间在17:00之前,不管结束时间是多少,都应该将业务办理完,改了一下代码,又通过了一组数据。

    永远渴望,大智若愚(stay hungry, stay foolish)
  • 相关阅读:
    HDFS体系结构
    HDFS核心设计
    1)HDFS分布式文件系统 2)HDFS核心设计 3 )HDFS体系结构
    大数据的特征
    zookeeper原理
    Hadoop安装手册
    微信公众号开发
    一、Ajax 二、JSON数据格式 三、Ajax+Jquery 四、分页的实现
    设计模式--工厂模式
    Spring MVC 配置文件设置全局编码
  • 原文地址:https://www.cnblogs.com/h-hkai/p/12595430.html
Copyright © 2011-2022 走看看