zoukankan      html  css  js  c++  java
  • 1086 Tree Traversals Again

    An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.


    Figure 1

    Input Specification:

    Each input file contains one test case. For each case, the first line contains a positive integer N (≤) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2 lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

    Output Specification:

    For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

    Sample Input:

    6
    Push 1
    Push 2
    Push 3
    Pop
    Pop
    Push 4
    Pop
    Pop
    Push 5
    Push 6
    Pop
    Pop
    
     

    Sample Output:

    3 4 2 6 5 1

    题意:

    采用非递归的方式来确定一颗二叉树,然后将这颗二叉树按照后序遍历的方式来输出。

    思路:

    这道题用到的理论知识就是通过一棵二叉树的先序遍历和中序遍历来构建这棵树,当然前提是你能够看出来进栈的序列是先序遍历的结果,出栈的序列是中序遍历的结果。构建树的代码(递归):

    Node CreateTree(int left, int right){
        if(left > right) return NULL;
        int root = preOrder[cur];
        cur++;
        int rootIndex = findRootIndex(root);
        Node T = new TreeNode();
        T->num = root;
        if(left != right){
            T->left = CreateTree(left,rootIndex-1);
            T->right = CreateTree(rootIndex+1,right);
        }
        return T;
    }
    

    Code:

    #include<iostream>
    #include<queue>
    #include<stack>
    
    using namespace std;
    
    typedef struct Node *node;
    struct Node {
        int value;
        node leftSon;
        node rightSon;
        node father;
        Node():value(), leftSon(), rightSon(), father(){}
    };
    
    void postOrder(node h) {
        if (h != NULL) {
            postOrder(h->leftSon);
            postOrder(h->rightSon);
            cout << h->value << " ";
        }
    }
    
    int main() {
        int n;
        cin >> n;
        getchar();
        string str, op, num;
        int pos;
        queue<string> q;
        stack<int> s;
        stack<string> leftOrRight;
        for (int i = 0; i < n*2; ++i) {
            getline(cin, str);
            if (str[1] == 'u') {
                pos = str.find(' ');
                op = str.substr(0, pos);
                num = str.substr(pos+1);
                q.push(op);
                q.push(num);
            } else {
                q.push(str);
            }
        }
    
        node head = new Node();
        node prt = head;
        while (!q.empty()) {
            if (q.front() == "Push") {
                q.pop();
                int value = stoi(q.front());
                s.push(value);
                q.pop();
                node temp = new Node();
                if (prt->leftSon) {
                    leftOrRight.push("right");
                    prt->rightSon = temp;
                    temp->father = prt;
                } else {
                    leftOrRight.push("left");
                    prt->leftSon = temp;
                    temp->father = prt;         
                }
                prt = temp;
            } else {
                q.pop();
                if (leftOrRight.top() == "left") prt = prt->father;
                prt->value = s.top();
                if (leftOrRight.top() == "right") prt = prt->father;
                s.pop();
                leftOrRight.pop();
            }
        }
        postOrder(prt);
        return 0;
    }

    以上是我写的代码,因为没有注意到题目中暗含着两种遍历,所以写的代码也很乱,当然也是错误的。


    以下的代码来自:https://blog.csdn.net/xyt8023y/article/details/47443489 

    #include <iostream>
    #include <stdio.h>
    #include <vector>
    #include <string>
    #include <sstream>
    #include <stack>
     
    using namespace std;
     
    int N,cur;
    vector<int> preOrder;
    vector<int> inOrder;
     
    typedef struct TreeNode *Node;
    struct TreeNode{
        int num;
        Node left,right;
     
        TreeNode(){
            left = NULL;
            right = NULL;
        }
     
    };
     
    int findRootIndex(int rootNum){
     
        for(int i = 0;i < N; i++){
            if(inOrder[i] == rootNum){
                return i;
            }
        }
        return -1;
     
    }
     
    Node CreateTree(int left, int right){
        if(left > right) return NULL;
        int root = preOrder[cur];
        cur++;
        int rootIndex = findRootIndex(root);
        Node T = new TreeNode();
        T->num = root;
        if(left != right){
            T->left = CreateTree(left,rootIndex-1);
            T->right = CreateTree(rootIndex+1,right);
        }
        return T;
    }
     
    bool firstOutPut = true;
    void PostOrder(Node T){
        if(!T) return;
        PostOrder(T->left);
        PostOrder(T->right);
        if(firstOutPut){
            printf("%d",T->num);
            firstOutPut = false;
        }else{
            printf(" %d",T->num);
        }
    }
     
     
    int main()
    {
        stringstream ss;
        string Nstr;
        getline(cin,Nstr);
        ss << Nstr;
        ss >> N;
        ss.clear();
        string input;
        stack<int> stk;
        int value;
        for(int i = 0; i < N * 2; i++){
            getline(cin,input);
            if(input[1] == 'u'){
                string num = input.substr(5);
                ss << num;
                ss >> value;
                ss.clear();
                stk.push(value);
                preOrder.push_back(value);
            }else{
                value = stk.top();
                stk.pop();
                inOrder.push_back(value);
            }
        }
        Node T = CreateTree(0,N-1);
        PostOrder(T);
        return 0;
    }
    

      

    值得注意的是cur并没有赋初值,测试发现他的初值默认为0.

    永远渴望,大智若愚(stay hungry, stay foolish)
  • 相关阅读:
    51nod1370 排列与操作
    2019-11-20-Github-给仓库上传-NuGet-库
    2019-11-20-Github-给仓库上传-NuGet-库
    2019-6-5-WPF-隐藏系统窗口菜单
    2019-6-5-WPF-隐藏系统窗口菜单
    2019-8-31-AutoHotKey-用打码的快捷键
    2019-8-31-AutoHotKey-用打码的快捷键
    2019-4-10-win10-uwp-自定义标记扩展
    2019-4-10-win10-uwp-自定义标记扩展
    2018-9-3-C#-const-和-readonly-有什么区别
  • 原文地址:https://www.cnblogs.com/h-hkai/p/12639992.html
Copyright © 2011-2022 走看看