zoukankan      html  css  js  c++  java
  • 1152 Google Recruitment

    In July 2004, Google posted on a giant billboard along Highway 101 in Silicon Valley (shown in the picture below) for recruitment. The content is super-simple, a URL consisting of the first 10-digit prime found in consecutive digits of the natural constant e. The person who could find this prime number could go to the next step in Google's hiring process by visiting this website.

    prime.jpg

    The natural constant e is a well known transcendental number(超越数). The first several digits are: e = 2.718281828459045235360287471352662497757247093699959574966967627724076630353547594571382178525166427427466391932003059921... where the 10 digits in bold are the answer to Google's question.

    Now you are asked to solve a more general problem: find the first K-digit prime in consecutive digits of any given L-digit number.

    Input Specification:

    Each input file contains one test case. Each case first gives in a line two positive integers: L (≤ 1,000) and K (< 10), which are the numbers of digits of the given number and the prime to be found, respectively. Then the L-digit number N is given in the next line.

    Output Specification:

    For each test case, print in a line the first K-digit prime in consecutive digits of N. If such a number does not exist, output 404 instead. Note: the leading zeroes must also be counted as part of the K digits. For example, to find the 4-digit prime in 200236, 0023 is a solution. However the first digit 2 must not be treated as a solution 0002 since the leading zeroes are not in the original number.

    Sample Input 1:

    20 5
    23654987725541023819
    
     

    Sample Output 1:

    49877
    
     

    Sample Input 2:

    10 3
    2468024680
    
     

    Sample Output 2:

    404

    题意:

    给出一串数字找出这串数字中第一个长度为k的素数。

    思路:

    遍历,然后判断是不是素数。

    Code:

    #include<iostream>
    #include<string>
    
    using namespace std;
    
    bool isPrime(int n) {
        if (n == 0 || n == 1) return false;
        for (int i = 2; i*i <= n; ++i) {
            if (n % i == 0) return false;
        }
        return true;
    }
    
    int main() {
        int n, k, temp;
        string str, sub;
        cin >> n >> k >> str;
        for (int i = 0; i+k <= n; ++i) {
            sub = str.substr(i, k);
            temp = stoi(sub); 
            if (isPrime(temp)) {
                cout << sub << endl;
                return 0;
            }
        }
    
        cout << "404" << endl;
    
        return 0;
    }
    永远渴望,大智若愚(stay hungry, stay foolish)
  • 相关阅读:
    什么是Azkaban?
    设计模式 应用场景
    初识Nginx
    C++著名程序库的比较和学习经验(STL.Boost.GUI.XML.网络等等)
    C++对象模型笔记之程序设计模型
    深度探索C++对象模型之C++对象模型笔记
    对于数据库设计者而言,在设计表属性类型时应该考虑哪些问题?
    Thread 多线程 同步
    Thread sleep()休眠
    Java 多线程(Thread)学习
  • 原文地址:https://www.cnblogs.com/h-hkai/p/12673386.html
Copyright © 2011-2022 走看看