zoukankan      html  css  js  c++  java
  • 1152 Google Recruitment

    In July 2004, Google posted on a giant billboard along Highway 101 in Silicon Valley (shown in the picture below) for recruitment. The content is super-simple, a URL consisting of the first 10-digit prime found in consecutive digits of the natural constant e. The person who could find this prime number could go to the next step in Google's hiring process by visiting this website.

    prime.jpg

    The natural constant e is a well known transcendental number(超越数). The first several digits are: e = 2.718281828459045235360287471352662497757247093699959574966967627724076630353547594571382178525166427427466391932003059921... where the 10 digits in bold are the answer to Google's question.

    Now you are asked to solve a more general problem: find the first K-digit prime in consecutive digits of any given L-digit number.

    Input Specification:

    Each input file contains one test case. Each case first gives in a line two positive integers: L (≤ 1,000) and K (< 10), which are the numbers of digits of the given number and the prime to be found, respectively. Then the L-digit number N is given in the next line.

    Output Specification:

    For each test case, print in a line the first K-digit prime in consecutive digits of N. If such a number does not exist, output 404 instead. Note: the leading zeroes must also be counted as part of the K digits. For example, to find the 4-digit prime in 200236, 0023 is a solution. However the first digit 2 must not be treated as a solution 0002 since the leading zeroes are not in the original number.

    Sample Input 1:

    20 5
    23654987725541023819
    
     

    Sample Output 1:

    49877
    
     

    Sample Input 2:

    10 3
    2468024680
    
     

    Sample Output 2:

    404

    题意:

    给出一串数字找出这串数字中第一个长度为k的素数。

    思路:

    遍历,然后判断是不是素数。

    Code:

    #include<iostream>
    #include<string>
    
    using namespace std;
    
    bool isPrime(int n) {
        if (n == 0 || n == 1) return false;
        for (int i = 2; i*i <= n; ++i) {
            if (n % i == 0) return false;
        }
        return true;
    }
    
    int main() {
        int n, k, temp;
        string str, sub;
        cin >> n >> k >> str;
        for (int i = 0; i+k <= n; ++i) {
            sub = str.substr(i, k);
            temp = stoi(sub); 
            if (isPrime(temp)) {
                cout << sub << endl;
                return 0;
            }
        }
    
        cout << "404" << endl;
    
        return 0;
    }
    永远渴望,大智若愚(stay hungry, stay foolish)
  • 相关阅读:
    Sql诊断之Explain
    Cenos7安装docker环境以及docker-compose
    uniapp苹果内购获取不到苹果的iap支付通道
    iOS云打包如何设置通用链接等Capabilities配置
    iOS应用id,套装id,appid,BundleID申请教程
    利用Appuploader在window上申请IOS开发所需要的证书及描述文件
    浅析GET和POST请求的本质区别以及关于get请求的长度限制到底是多少的问题
    iOS苹果开发者组织账号申请时的坑
    apache开源项目--HIVE
    [Unit testing Java] Unit testing Junit Controller
  • 原文地址:https://www.cnblogs.com/h-hkai/p/12673386.html
Copyright © 2011-2022 走看看