zoukankan      html  css  js  c++  java
  • 1150 Travelling Salesman Problem

    The "travelling salesman problem" asks the following question: "Given a list of cities and the distances between each pair of cities, what is the shortest possible route that visits each city and returns to the origin city?" It is an NP-hard problem in combinatorial optimization, important in operations research and theoretical computer science. (Quoted from "https://en.wikipedia.org/wiki/Travelling_salesman_problem".)

    In this problem, you are supposed to find, from a given list of cycles, the one that is the closest to the solution of a travelling salesman problem.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains 2 positive integers N (2), the number of cities, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format City1 City2 Dist, where the cities are numbered from 1 to N and the distance Dist is positive and is no more than 100. The next line gives a positive integer K which is the number of paths, followed by K lines of paths, each in the format:

    n C​1​​ C​2​​ ... C​n​​

    where n is the number of cities in the list, and C​i​​'s are the cities on a path.

    Output Specification:

    For each path, print in a line Path X: TotalDist (Description) where X is the index (starting from 1) of that path, TotalDist its total distance (if this distance does not exist, output NA instead), and Description is one of the following:

    • TS simple cycle if it is a simple cycle that visits every city;
    • TS cycle if it is a cycle that visits every city, but not a simple cycle;
    • Not a TS cycle if it is NOT a cycle that visits every city.

    Finally print in a line Shortest Dist(X) = TotalDist where X is the index of the cycle that is the closest to the solution of a travelling salesman problem, and TotalDist is its total distance. It is guaranteed that such a solution is unique.

    Sample Input:

    6 10
    6 2 1
    3 4 1
    1 5 1
    2 5 1
    3 1 8
    4 1 6
    1 6 1
    6 3 1
    1 2 1
    4 5 1
    7
    7 5 1 4 3 6 2 5
    7 6 1 3 4 5 2 6
    6 5 1 4 3 6 2
    9 6 2 1 6 3 4 5 2 6
    4 1 2 5 1
    7 6 1 2 5 4 3 1
    7 6 3 2 5 4 1 6
    
     

    Sample Output:

    Path 1: 11 (TS simple cycle)
    Path 2: 13 (TS simple cycle)
    Path 3: 10 (Not a TS cycle)
    Path 4: 8 (TS cycle)
    Path 5: 3 (Not a TS cycle)
    Path 6: 13 (Not a TS cycle)
    Path 7: NA (Not a TS cycle)
    Shortest Dist(4) = 8

    题意:

    给处理个无向图,以及各条边的权重。然后给出一条旅行路径,判断这条路径是 TS simple cycle, 还是TS cycle,或者不是TS cycle。

    思路:

    用连接矩阵来存储无向图,然后模拟旅行的过程。用set来判断一个城市是不是经过了两次。

    Code:

    #include<iostream>
    #include<vector>
    #include<set>
    
    using namespace std;
    
    const int inf = 0x7fffffff;
    
    int main() {
        int n, m;
        cin >> n >> m;
        vector<vector<int> > martix(n+1, vector<int>(n+1, -1));
        int c1, c2, d;
        for (int i = 0; i < m; ++i) {
            cin >> c1 >> c2 >> d;
            martix[c1][c2] = martix[c2][c1] = d;
        }
    
        set<int> s;
        int shortestDist = inf, sdIndex;
        int k, t, index = 1, dis, start;
        bool isTSSimpleCycle, flag;
        cin >> k;
        for (int i = 0; i < k; ++i) {
            cin >> t >> start;
            flag = true;
            isTSSimpleCycle = true;
            dis = 0, c1 = start;
            s.clear();
            for (int j = 1; j < t; ++j) {
                cin >> c2;
                if (s.find(c2) != s.end()) {
                    isTSSimpleCycle = false;
                } else {
                    s.insert(c2);
                }
                if (martix[c1][c2] == -1) {
                    flag = false;
                } else {
                    dis += martix[c1][c2];
                }
                c1 = c2;
            }
            if (c1 == start && flag) {
                if (isTSSimpleCycle && s.size() == n) {
                    if (shortestDist > dis) {
                        sdIndex = index;
                        shortestDist = dis;
                    }                
                    cout << "Path " << index << ": " << dis << " (TS simple cycle)" << endl;
                } else if (s.size() == n){
                    if (shortestDist > dis) {
                        sdIndex = index;
                        shortestDist = dis;
                    }
                    cout << "Path " << index << ": " << dis << " (TS cycle)" << endl;
                } else {
                    cout << "Path " << index << ": " << dis << " (Not a TS cycle)" << endl;
                }
            } else {
                if (flag) {
                    cout << "Path " << index << ": " << dis << " (Not a TS cycle)" << endl;
                } else {
                    cout << "Path " << index << ": NA" << " (Not a TS cycle)" << endl;
                }
            }
            index++;
        }
        cout << "Shortest Dist(" << sdIndex << ") = " << shortestDist << endl;
        return 0;
    }
    永远渴望,大智若愚(stay hungry, stay foolish)
  • 相关阅读:
    简单计算器
    dfs(通过控制点的编号来得出每个点的坐标)
    dfs(通过控制点的编号来得出每个点的坐标)
    神奇的 组合数
    神奇的 组合数
    B. Light It Up
    B. Light It Up
    Python 字符串
    Python radians() 函数
    Python degrees() 函数
  • 原文地址:https://www.cnblogs.com/h-hkai/p/12676337.html
Copyright © 2011-2022 走看看