zoukankan      html  css  js  c++  java
  • uva

                  

    11988 - Broken Keyboard (a.k.a. Beiju Text)

    You’re typing a long text with a broken keyboard. Well it’s not so badly broken. The only problem
    with the keyboard is that sometimes the “home” key or the “end” key gets automatically pressed
    (internally).
    You’re not aware of this issue, since you’re focusing on the text and did not even turn on the
    monitor! After you finished typing, you can see a text on the screen (if you turn on the monitor).
    In Chinese, we can call it Beiju. Your task is to find the Beiju text.
    Input
    There are several test cases. Each test case is a single line containing at least one and at most 100,000
    letters, underscores and two special characters ‘[’ and ‘]’. ‘[’ means the “Home” key is pressed
    internally, and ‘]’ means the “End” key is pressed internally. The input is terminated by end-of-file
    (EOF).
    Output
    For each case, print the Beiju text on the screen.
    Sample Input
    This_is_a_[Beiju]_text
    [[]][][]Happy_Birthday_to_Tsinghua_University
    Sample Output
    BeijuThis_is_a__text
    Happy_Birthday_to_Tsinghua_University

    题解:

    给定一个字符串,内部含有光标转移指令,

    【代表光标移向文章头,】代表光标移向文章尾,问最终在屏幕上显示的字符串序列是?

    Cur代表当前光标的位置,en代表当前结束的位置。。。模拟输入就好了,用链表;

    链表,好题,代码好吊,看了半天,越看越感觉吊;

    代码:

    #include<iostream>
    #include<cstring>
    #include<cmath>
    #include<cstdio>
    #include<algorithm>
    using namespace std;
    const int MAXN=1e5+100;
    int en,cur,next[MAXN];
    char s[MAXN];
    int main(){
    	while(~scanf("%s",s+1)){
    		int len=strlen(s+1);
    		cur=en=0;
    		next[0]=0;
    		for(int i=1;i<=len;i++){
    			if(s[i]=='[')cur=0;
    			else if(s[i]==']')cur=en;
    			else{
    				next[i]=next[cur];
    				next[cur]=i;
    				if(cur==en)en=i;
    				cur=i;
    			}
    		}
    		for(int i=next[0];i!=0;i=next[i])printf("%c",s[i]);
    		puts("");
    	}
    	return 0;
    }
    

      

  • 相关阅读:
    Linux下面编译安装ffmpeg
    Fidder简单使用方法(HTTPS抓取和url替换)
    关于一下个阶段的计划
    JAVA的随机的字符串的封装(基本上够用了)
    Shell Script中的间接变量引用
    进程概念
    int main(int argc, char *argv[])的解读
    存储数组数据到SharedPreferences
    C语言中的基本声明
    C中关于指针数组的用法
  • 原文地址:https://www.cnblogs.com/handsomecui/p/4984810.html
Copyright © 2011-2022 走看看