zoukankan      html  css  js  c++  java
  • 3644

    3644 - X-Plosives

    A secret service developed a new kind of explosive that attain its volatile property only when a specific
    association of products occurs. Each product is a mix of two different simple compounds, to which we
    call a binding pair. If N > 2, then mixing N different binding pairs containing N simple compounds
    creates a powerful explosive. For example, the binding pairs A+B, B+C, A+C (three pairs, three
    compounds) result in an explosive, while A+B, B+C, A+D (three pairs, four compounds) does not.
    You are not a secret agent but only a guy in a delivery agency with one dangerous problem: receive
    binding pairs in sequential order and place them in a cargo ship. However, you must avoid placing in
    the same room an explosive association. So, after placing a set of pairs, if you receive one pair that
    might produce an explosion with some of the pairs already in stock, you must refuse it, otherwise, you
    must accept it.
    An example. Lets assume you receive the following sequence: A+B, G+B, D+F, A+E, E+G,
    F+H. You would accept the first four pairs but then refuse E+G since it would be possible to make the
    following explosive with the previous pairs: A+B, G+B, A+E, E+G (4 pairs with 4 simple compounds).
    Finally, you would accept the last pair, F+H.
    Compute the number of refusals given a sequence of binding pairs.
    Input
    The input will contain several test cases, each of them as described below. Consecutive
    test cases are separated by a single blank line.
    Instead of letters we will use integers to represent compounds. The input contains several lines.
    Each line (except the last) consists of two integers (each integer lies between 0 and 105
    ) separated by
    a single space, representing a binding pair.
    Each test case ends in a line with the number ‘-1’. You may assume that no repeated binding pairs
    appears in the input.
    Output
    For each test case, the output must follow the description below.
    A single line with the number of refusals.
    Sample Input
    1 2
    3 4
    3 5
    3 1
    2 3
    4 1
    2 6
    6 5
    -1
    Sample Output
    3

    题解:如果k个化合物正好有k个元素就爆炸,求不能放的化合物的个数,其实就是并差集环的个数:

    代码:

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<cmath>
    #include<algorithm>
    #include<queue>
    #include<vector>
    #include<stack>
    using namespace std;
    const int INF=0x3f3f3f3f;
    #define mem(x,y) memset(x,y,sizeof(x))
    #define SI(x) scanf("%d",&x)
    #define SL(x) scanf("%lld",&x)
    #define PI(x) printf("%d",x)
    #define PL(x) printf("%lld",x)
    #define P_ printf(" ")
    #define T_T while(T--)
    #define F(i,s,x) for(i=s;i<x;i++)
    const double PI=acos(-1.0);
    typedef long long LL;
    const int MAXN=1e5+100;
    int pre[MAXN];
    int find(int x){
    	return x==pre[x]?x:pre[x]=find(pre[x]);
    }
    bool merge(int a,int b){
    	if(pre[a]==-1)pre[a]=a;
    	if(pre[b]==-1)pre[b]=b;
    	int f1,f2;
    	f1=find(a);f2=find(b);
    	if(f1!=f2){
    		pre[f1]=f2;return false;
    	}
    	else return true;
    }
    int main(){
    	int a,b;
    	mem(pre,-1);
    	int ans=0;
    	while(~SI(a)){
    		if(a==-1){
    			PI(ans);puts("");
    			mem(pre,-1);
    			ans=0;
    			continue;
    		}
    		SI(b);
    	if(merge(a,b))ans++;
    	}
    	return 0;
    }
    

      

  • 相关阅读:
    C++疑难杂症
    程序中的错误、异常处理框架设计
    客户端ARPG角色行为模型
    http协议
    MySQL数据库开发(2)
    MySQL数据库开发(1)
    网络编程进阶及并发编程
    网络编程-SOCKET开发
    面向对象编程
    常用模块
  • 原文地址:https://www.cnblogs.com/handsomecui/p/5011524.html
Copyright © 2011-2022 走看看