zoukankan      html  css  js  c++  java
  • Ignatius and the Princess II(全排列)

    Ignatius and the Princess II

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 6359    Accepted Submission(s): 3760

    Problem Description
    Now our hero finds the door to the BEelzebub feng5166. He opens the door and finds feng5166 is about to kill our pretty Princess. But now the BEelzebub has to beat our hero first. feng5166 says, "I have three question for you, if you can work them out, I will release the Princess, or you will be my dinner, too." Ignatius says confidently, "OK, at last, I will save the Princess."
    "Now I will show you the first problem." feng5166 says, "Given a sequence of number 1 to N, we define that 1,2,3...N-1,N is the smallest sequence among all the sequence which can be composed with number 1 to N(each number can be and should be use only once in this problem). So it's easy to see the second smallest sequence is 1,2,3...N,N-1. Now I will give you two numbers, N and M. You should tell me the Mth smallest sequence which is composed with number 1 to N. It's easy, isn't is? Hahahahaha......" Can you help Ignatius to solve this problem?
     
    Input
    The input contains several test cases. Each test case consists of two numbers, N and M(1<=N<=1000, 1<=M<=10000). You may assume that there is always a sequence satisfied the BEelzebub's demand. The input is terminated by the end of file.
     
    Output
    For each test case, you only have to output the sequence satisfied the BEelzebub's demand. When output a sequence, you should print a space between two numbers, but do not output any spaces after the last number.
     
    Sample Input
    6 4 11 8
     
    Sample Output
    1 2 3 5 6 4 1 2 3 4 5 6 7 9 8 11 10
     

    题解:水题,让找第M小的序列;它这里的小应该就是逆序数从小到大;

    其实就是个全排列,递归下就好了;

    代码:

    #include<cstdio>
    #include<cstring>
    #include<cmath>
    #include<iostream>
    #include<algorithm>
    using namespace std;
    #define mem(x,y) memset(x,y,sizeof(x))
    #define SI(x) scanf("%d",&x)
    #define PI(x) printf("%d",x)
    #define P_ printf(" ")
    const int MAXN=1010;
    int ans[MAXN];
    int vis[MAXN];
    int N,M;
    int cnt;
    int flot;
    void dfs(int num){
        if(flot)return;
        if(num==N){
            cnt++;
            if(cnt==M){
                for(int i=0;i<N;i++){
                    if(i)P_;
                    printf("%d",ans[i]);
                }
                puts("");
                flot=1;
            }
            return ;
        }
        for(int i=0;i<N;i++){
            if(vis[i+1])continue;
            ans[num]=i+1;
            vis[i+1]=1;
            dfs(num+1);
            vis[i+1]=0;
        }
    }
    int main(){
         while(~scanf("%d%d",&N,&M)){
             mem(vis,0);
             cnt=flot=0;
             dfs(0);
         }
        return 0;
    } 
  • 相关阅读:
    kubernetes 笔记 1
    Linux 性能优化笔记 --CPU总结
    Linux 性能优化笔记 --CPU
    RedHat OpenShift QuickStart 2.4 容器主机
    docker 常用命令
    RedHat OpenShift QuickStart 2.3 容器注册
    SpringBoot自动配置源码
    RedHat OpenShift QuickStart 2.2 容器镜像
    RedHat OpenShift QuickStart 2.1 容器介绍
    RedHat OpenShift QuickStart 1.2 容器中传入/出文件
  • 原文地址:https://www.cnblogs.com/handsomecui/p/5244613.html
Copyright © 2011-2022 走看看