zoukankan      html  css  js  c++  java
  • A Corrupt Mayor's Performance Art(线段树区间更新+位运算,颜色段种类)

    A Corrupt Mayor's Performance Art

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 100000/100000 K (Java/Others) Total Submission(s): 1905    Accepted Submission(s): 668

    Problem Description
    Corrupt governors always find ways to get dirty money. Paint something, then sell the worthless painting at a high price to someone who wants to bribe him/her on an auction, this seemed a safe way for mayor X to make money.
    Because a lot of people praised mayor X's painting(of course, X was a mayor), mayor X believed more and more that he was a very talented painter. Soon mayor X was not satisfied with only making money. He wanted to be a famous painter. So he joined the local painting associates. Other painters had to elect him as the chairman of the associates. Then his painting sold at better price.
    The local middle school from which mayor X graduated, wanted to beat mayor X's horse fart(In Chinese English, beating one's horse fart means flattering one hard). They built a wall, and invited mayor X to paint on it. Mayor X was very happy. But he really had no idea about what to paint because he could only paint very abstract paintings which nobody really understand. Mayor X's secretary suggested that he could make this thing not only a painting, but also a performance art work.
    This was the secretary's idea:
    The wall was divided into N segments and the width of each segment was one cun(cun is a Chinese length unit). All segments were numbered from 1 to N, from left to right. There were 30 kinds of colors mayor X could use to paint the wall. They named those colors as color 1, color 2 .... color 30. The wall's original color was color 2. Every time mayor X would paint some consecutive segments with a certain kind of color, and he did this for many times. Trying to make his performance art fancy, mayor X declared that at any moment, if someone asked how many kind of colors were there on any consecutive segments, he could give the number immediately without counting.
    But mayor X didn't know how to give the right answer. Your friend, Mr. W was an secret officer of anti-corruption bureau, he helped mayor X on this problem and gained his trust. Do you know how Mr. Q did this?
     
    Input
    There are several test cases.
    For each test case:
    The first line contains two integers, N and M ,meaning that the wall is divided into N segments and there are M operations(0 < N <= 1,000,000; 0<M<=100,000) 
    Then M lines follow, each representing an operation. There are two kinds of operations, as described below: 
    1) P a b c  a, b and c are integers. This operation means that mayor X painted all segments from segment a to segment b with color c ( 0 < a<=b <= N, 0 < c <= 30).
    2) Q a b a and b are integers. This is a query operation. It means that someone asked that how many kinds of colors were there from segment a to segment b ( 0 < a<=b <= N).
    Please note that the operations are given in time sequence.
    The input ends with M = 0 and N = 0.
     
    Output
    For each query operation, print all kinds of color on the queried segments. For color 1, print 1, for color 2, print 2 ... etc. And this color sequence must be in ascending order.
     
    Sample Input
    5 10 P 1 2 3 P 2 3 4 Q 2 3 Q 1 3 P 3 5 4 P 1 2 7 Q 1 3 Q 3 4 P 5 5 8 Q 1 5 0 0
     
    Sample Output
    4 3 4 4 7 4 4 7 8
     

    题解:染色线段树,每次询问输出这段区间的颜色种类;位运算记录颜色;注意lazy传递的是相等,因为直接染色;

    代码:

    #include<stdio.h>
    #include<string.h>
    #include<algorithm>
    #include<iostream>
    #include<vector>
    #define LL long long 
    using namespace std;
    #define ll root<<1
    #define rr root<<1|1
    #define lson ll, l, mid
    #define rson rr, mid + 1, r
    int ans;
    const int MAXN = 1e6 + 100;
    int tree[MAXN << 2];
    int lazy[MAXN << 2];
    int p[35];
    void pushup(int root){
        tree[root] = tree[ll] | tree[rr];
    }
    void pushdown(int root){
        if(lazy[root]){
            lazy[ll] = lazy[root];
            lazy[rr] = lazy[root];
            tree[ll] = lazy[root];
            tree[rr] = lazy[root];
            lazy[root] = 0;
        }
    }
    void build(int root, int l, int r){
        lazy[root] = 0;
        int mid = (l + r) >> 1;
        if(l == r){
            tree[root] = 1 << (2 - 1);
            return;
        }
        build(lson);
        build(rson);
        pushup(root);
    }
    void update(int root, int l, int r, int L, int R, int C){
        int mid = (l + r) >> 1;
        if(l >= L && r <= R){
            tree[root] = 1 << (C - 1);
            lazy[root] = 1 << (C - 1);
            return;
        }
        pushdown(root);
        if(mid >= L)update(lson, L, R, C);
        if(mid < R)update(rson, L, R, C);
        pushup(root);
    }
    void query(int root, int l, int r, int L, int R){
        int mid = (l + r) >> 1;
        if(l >= L && r <= R){
            ans |= tree[root];
            return;
        }
        pushdown(root);
        if(mid >= L)query(lson, L, R);
        if(mid < R)query(rson, L, R);
    }
    int main(){
        int N, M;
        char s[5];
        while(scanf("%d%d", &N, &M), N|M){
            build(1, 1, N);
            while(M--){
                int l, r, c;
                scanf("%s%d%d", s, &l, &r);
                if(s[0] == 'P'){
                    scanf("%d", &c);
                    update(1, 1, N, l, r, c);
                }
                else{
                    ans = 0;
                    int tp = 0, i = 1;
                    query(1, 1, N, l, r);
                    while(ans){
                        if(ans & 1)
                            p[tp++] = i;
                        i++;
                        ans >>= 1;
                    }
                    for(int i = 0; i < tp; i++){
                        if(i)printf(" ");
                        printf("%d", p[i]);
                    }
                    puts("");
                }
            }
        }
        return 0;
    }
  • 相关阅读:
    洛谷 P1068 分数线划定
    LeetCode 7. Reverse Integer
    LeetCode 504. Base 7
    洛谷 P1598 垂直柱状图
    用户场景
    个人博客03
    个人博客02
    个人博客01
    《构建之法》阅读笔记03
    学习进度条(第四周)
  • 原文地址:https://www.cnblogs.com/handsomecui/p/5422857.html
Copyright © 2011-2022 走看看