zoukankan      html  css  js  c++  java
  • Beans(dp,两次dp)

    Beans

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 4141    Accepted Submission(s): 1964

    Problem Description
    Bean-eating is an interesting game, everyone owns an M*N matrix, which is filled with different qualities beans. Meantime, there is only one bean in any 1*1 grid. Now you want to eat the beans and collect the qualities, but everyone must obey by the following rules: if you eat the bean at the coordinate(x, y), you can’t eat the beans anyway at the coordinates listed (if exiting): (x, y-1), (x, y+1), and the both rows whose abscissas are x-1 and x+1.
    Now, how much qualities can you eat and then get ?
     
    Input
    There are a few cases. In each case, there are two integer M (row number) and N (column number). The next M lines each contain N integers, representing the qualities of the beans. We can make sure that the quality of bean isn't beyond 1000, and 1<=M*N<=200000.
     
    Output
    For each case, you just output the MAX qualities you can eat and then get.
     
    Sample Input
    4 6 11 0 7 5 13 9 78 4 81 6 22 4 1 40 9 34 16 10 11 22 0 33 39 6
     
    Sample Output
    242
     

    题解:一次对行dp,一次对列dp;

    java超时了。。。c就不会

    代码:

    import java.util.Scanner;
    
    
    public class Beans {
        static int a[] = new int[200010], dp[] = new int[200010], DP[] = new int[200010], b[] = new int[200010];
        public static void main(String[] argvs){
            int M, N;
            Scanner cin = new Scanner(System.in);
            while(cin.hasNext()){
                M = cin.nextInt();
                N = cin.nextInt();
                for(int i = 0; i < M; i++){
                    DP[i] = 0;
                    for(int j = 0; j < N; j++){
                        dp[j] = 0;
                        a[j] = cin.nextInt();
                        if(j < 2)
                            dp[j] = a[j];
                        else 
                            dp[j] = Math.max(dp[j - 2] + a[j], dp[j - 1]);
                    }
                    DP[i] = dp[N - 1];
                    if(i < 2)
                        b[i] = DP[i];
                    else
                        b[i] = Math.max(b[i - 2] + DP[i], b[i - 1]);
                }
                System.out.println(b[M - 1]);
            }
            
        }
    }
  • 相关阅读:
    程序员书单_移动开发篇
    程序员书单_程序人生篇
    程序员书单_软考篇
    程序员书单_云计算篇
    程序员书单_数据库篇
    程序员书单_sshi框架篇
    程序员书单_软件工程篇
    程序员书单_项目管理篇
    Informatica在linux下安装搭建
    Informatica9.5.1创建资源库出错找不到libpmora8.so
  • 原文地址:https://www.cnblogs.com/handsomecui/p/5478676.html
Copyright © 2011-2022 走看看