zoukankan      html  css  js  c++  java
  • [Usaco2015 Feb]Censoring(bzoj 3942)

    Description

    Farmer John has purchased a subscription to Good Hooveskeeping magazine for his cows, so they have plenty of material to read while waiting around in the barn during milking sessions. Unfortunately, the latest issue contains a rather inappropriate article on how to cook the perfect steak, which FJ would rather his cows not see (clearly, the magazine is in need of better editorial oversight).

    FJ has taken all of the text from the magazine to create the string S of length at most 10^6 characters. From this, he would like to remove occurrences of a substring T to censor the inappropriate content. To do this, Farmer John finds the _first_ occurrence of T in S and deletes it. He then repeats the process again, deleting the first occurrence of T again, continuing until there are no more occurrences of T in S. Note that the deletion of one occurrence might create a new occurrence of T that didn't exist before.

    Please help FJ determine the final contents of S after censoring is complete

    有一个S串和一个T串,长度均小于1,000,000,设当前串为U串,然后从前往后枚举S串一个字符一个字符往U串里添加,若U串后缀为T,则去掉这个后缀继续流程。

    
    
    

    Input

    The first line will contain S. The second line will contain T. The length of T will be at most that of S, and all characters of S and T will be lower-case alphabet characters (in the range a..z).
     

    Output

    The string S after all deletions are complete. It is guaranteed that S will not become empty during the deletion process.

    
    
    

    Sample Input

    whatthemomooofun
    moo

    Sample Output

    whatthefun
    /*
      用KMP处理出fail数组,然后大力匹配即可。
      但不知道为什么我用hash写了一遍会WA,以后有空再看看。 
    */
    //WA代码:
    #include<cstdio>
    #include<cstring>
    #include<iostream>
    #define N 1000010
    #define P 31
    #define lon long long
    using namespace std;
    int n1,n2;lon p=1,S,hash[N],base[N];
    char s1[N],s2[N],s3[N];
    int main(){
        scanf("%s%s",s1+1,s2+1);
        n1=strlen(s1+1);n2=strlen(s2+1);
        for(int i=1;i<=n2;i++){
            S=S*P+s2[i]-'a';
            p*=P;
        }
        int len=0;
        for(int i=1;i<=n1;i++){
            s3[++len]=s1[i];
            hash[len]=hash[len-1]*P+s1[i]-'a';
            if(len<n2)continue;
            if(hash[len]-hash[len-n2]*p==S)len-=n2;
        }
        for(int i=1;i<=len;i++)printf("%c",s3[i]);
        return 0;
    }
    //AC代码:
    #include<cstdio>
    #include<iostream>
    #include<cstring>
    #define N 1000010
    using namespace std;
    int fail[N],next[N],n1,n2,top;
    char s1[N],s2[N],s3[N];
    int main(){
        scanf("%s%s",s1+1,s2+1);
        n1=strlen(s1+1);n2=strlen(s2+1);
        fail[1]=0;
        for(int i=2;i<=n2;i++){
            int p=fail[i-1];
            while(p&&s2[p+1]!=s2[i])p=fail[p];
            if(s2[p+1]==s2[i])p++;
            fail[i]=p;
        }
        next[0]=0;
        for(int i=1;i<=n1;i++){
            s3[++top]=s1[i];
            int p=next[top-1];
            while(p&&s1[i]!=s2[p+1])p=fail[p];
            if(s1[i]==s2[p+1])p++;
            next[top]=p;
            if(p==n2)top-=n2;
        }
        for(int i=1;i<=top;i++)printf("%c",s3[i]);
        return 0;
    }
  • 相关阅读:
    第四天 PYTHON 函数
    第四天 PYTHON 字符串格式化
    第四天 PYTHON 集合
    Linux使用sshfs挂载远程目录到本地
    linux通过安装包安装nginx和jdk
    使用ajax提交form表单,包括ajax文件上传
    Linux下mysql出错:ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)
    数据库连接池
    一台机器上安装两个tomcat
    mysql优化
  • 原文地址:https://www.cnblogs.com/harden/p/6245371.html
Copyright © 2011-2022 走看看