zoukankan      html  css  js  c++  java
  • [HDU 1520] Anniversary party

    Anniversary party

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 6078    Accepted Submission(s): 2752

    Problem Description
    There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.
     
    Input
    Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form: 
    L K 
    It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line 
    0 0
     
    Output
    Output should contain the maximal sum of guests' ratings.
     
    Sample Input
    7 1 1 1 1 1 1 1 1 3 2 3 6 4 7 4 4 5 3 5 0 0
     
    Sample Output
    5
     
    Source
    Ural State University Internal Contest October'2000 Students Session
     

    树形DP入门题目、、

    加了一个输入输出外挂、、无耻地飘进首页、、

    #include <iostream>
    #include <algorithm>
    #include <cstdio>
    #include <queue>
    #include <cmath>
    #include <map>
    #include <vector>
    #include <iterator>
    #include <cstring>
    #include <string>
    using namespace std;
    #pragma comment(linker, "/STACK:1024000000,1024000000")
    #define max(a,b) ((a)>(b)?(a):(b))
    #define min(a,b) ((a)<(b)?(a):(b))
    #define INF 0x7fffffff
    #define ll long long
    #define N 6010
    
    struct Edge
    {
        int to,next;
    }edge[N<<1];
    int head[N],tot;
    int n;
    int f[N];
    int val[N];
    int vis[N];
    int dp[N][2];
    
    template <class T>
    inline bool input(T &ret)
    {
        char c; int sgn;
        if(c=getchar(),c==EOF) return 0;
        while(c!='-'&&(c<'0'||c>'9')) c=getchar();
        sgn=(c=='-')?-1:1;
        ret=(c=='-')?0:(c-'0');
        while(c=getchar(),c>='0'&&c<='9') ret=ret*10+(c-'0');
        ret*=sgn;
        return 1;
    }
    
    inline void out(int x)
    {
        if(x>9) out(x/10);
        putchar(x%10+'0');
    }
    
    void init()
    {
        tot=0;
        memset(head,-1,sizeof(head));
        memset(f,0,sizeof(f));
        memset(dp,0,sizeof(dp));
        memset(vis,0,sizeof(vis));
    }
    
    void add(int x,int y)
    {
        edge[tot].to=y;
        edge[tot].next=head[x];
        head[x]=tot++;
    }
    
    void dfs(int u)
    {
        for(int i=head[u];i!=-1;i=edge[i].next)
        {
            int v=edge[i].to;
            if(!vis[v])
            {
                vis[v]=1;
                dfs(v);
                dp[u][1]+=dp[v][0];
                dp[u][0]+=max(dp[v][0],dp[v][1]);
            }
        }
        dp[u][1]+=val[u];
    }
    
    int main()
    {
        int i;
        while(input(n))
        {
            init();
            for(i=1;i<=n;i++)
            {
                input(val[i]);
            }
            int a,b;
            while(1)
            {
                input(a);
                input(b);
                if(a+b==0) break;
                f[a]=b;
                add(b,a);
            }
            int root=1;
            while(f[root])
            {
                root=f[root];
            }
            vis[root]=1;
            dfs(root);
            out(max(dp[root][0],dp[root][1]));
            putchar('
    ');
        }
        return 0;
    }
    趁着还有梦想、将AC进行到底~~~by 452181625
  • 相关阅读:
    flutter  安装教程
    使用TcpTrace小工具截获Web Service的SOAP报文
    移除TFS服务器关系
    webservice log4net日志写入失败
    php发送邮件功能(PHPMailer-master插件)
    Unity3d:延迟加载ScrollView的内容
    Unity3d:播放物理目录下的MP3文件
    installshield Basic 工程每次安装完提示重启电脑
    网站背景音乐源码
    Unity3d:加载Format是RGB24位的图片失败(加载图片显示问号)
  • 原文地址:https://www.cnblogs.com/hate13/p/4090290.html
Copyright © 2011-2022 走看看