zoukankan      html  css  js  c++  java
  • [HDU 1011] Starship Troopers

    Starship Troopers

    Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

    Total Submission(s): 11476    Accepted Submission(s): 3166 

    Problem Description
    You, the leader of Starship Troopers, are sent to destroy a base of the bugs. The base is built underground. It is actually a huge cavern, which consists of many rooms connected with tunnels. Each room is occupied by some bugs, and their brains hide in some of the rooms. Scientists have just developed a new weapon and want to experiment it on some brains. Your task is to destroy the whole base, and capture as many brains as possible.
    To kill all the bugs is always easier than to capture their brains. A map is drawn for you, with all the rooms marked by the amount of bugs inside, and the possibility of containing a brain. The cavern's structure is like a tree in such a way that there is one unique path leading to each room from the entrance. To finish the battle as soon as possible, you do not want to wait for the troopers to clear a room before advancing to the next one, instead you have to leave some troopers at each room passed to fight all the bugs inside. The troopers never re-enter a room where they have visited before.
    A starship trooper can fight against 20 bugs. Since you do not have enough troopers, you can only take some of the rooms and let the nerve gas do the rest of the job. At the mean time, you should maximize the possibility of capturing a brain. To simplify the problem, just maximize the sum of all the possibilities of containing brains for the taken rooms. Making such a plan is a difficult job. You need the help of a computer.
     
    Input
    The input contains several test cases. The first line of each test case contains two integers N (0 < N <= 100) and M (0 <= M <= 100), which are the number of rooms in the cavern and the number of starship troopers you have, respectively. The following N lines give the description of the rooms. Each line contains two non-negative integers -- the amount of bugs inside and the possibility of containing a brain, respectively. The next N - 1 lines give the description of tunnels. Each tunnel is described by two integers, which are the indices of the two rooms it connects. Rooms are numbered from 1 and room 1 is the entrance to the cavern.
    The last test case is followed by two -1's.
     
    Output
    For each test case, print on a single line the maximum sum of all the possibilities of containing brains for the taken rooms.
     
    Sample Input
    5 10 50 10 40 10 40 20 65 30 70 30 1 2 1 3 2 4 2 5 1 1 20 7 -1 -1
     
    Sample Output
    50 7

    树形背包入门题、注意理解

    #include <iostream>
    #include <cstring>
    #include <cstdio>
    using namespace std;
    
    #define N 110
    struct Edge
    {
        int next,to;
    }edge[N*N/2];
    int head[N<<1],tot;
    
    int n,m;
    int p[N];
    int vis[N];
    int bugs[N];
    int dp[N][N];
    
    void dfs(int u)
    {
        vis[u]=1;
        int i,j,k,v;
        int r=bugs[u]%20?bugs[u]/20+1:bugs[u]/20;
        for(i=r;i<=m;i++)
        {
            dp[u][i]=p[u];
        }
        for(i=head[u];i!=-1;i=edge[i].next)
        {
            v=edge[i].to;
            if(!vis[v])
            {
                dfs(v);
                for(j=m;j>=r;j--)
                {
                    for(k=1;k<=j-r;k++)
                    {
                        dp[u][j]=max(dp[u][j],dp[u][j-k]+ dp[v][k]);
                    }
                }
            }
        }
    }
    void add(int x,int y)
    {
        edge[tot].to=y;
        edge[tot].next=head[x];
        head[x]=tot++;
    }
    void init()
    {
        tot=0;
        memset(head,-1,sizeof(head));
        memset(dp,0,sizeof(dp));
        memset(vis,0,sizeof(vis));
    }
    int main()
    {
        while(scanf("%d%d",&n,&m), (n+1)||(m+1))
        {
            init();
            for(int i=1;i<=n;i++)
            {
                scanf("%d%d",&bugs[i],&p[i]);
            }
            for(int i=1;i<n;i++)
            {
                int a,b;
                scanf("%d%d",&a,&b);
                add(a,b);
                add(b,a);
            }
            if(m==0) cout<<0<<endl;             //0个士兵,一无所获
            else
            {
                dfs(1);
                cout<<dp[1][m]<<endl;
            }
        }
        return 0;
    }
    趁着还有梦想、将AC进行到底~~~by 452181625
  • 相关阅读:
    mysql日志
    验证栈序列
    限流方案分析
    集合
    数据结构-树
    链表的中间节点
    PHP实现链表
    php扩展安装方式
    2017 Multi-University Training Contest
    用LCT解一类动态图的问题
  • 原文地址:https://www.cnblogs.com/hate13/p/4094006.html
Copyright © 2011-2022 走看看