zoukankan      html  css  js  c++  java
  • [ZOJ 3623] Battle Ships

    Battle Ships

    Time Limit: 2 Seconds      Memory Limit: 65536 KB

    Battle Ships is a new game which is similar to Star Craft. In this game, the enemy builds a defense tower, which has L longevity. The player has a military factory, which can produce N kinds of battle ships. The factory takes ti seconds to produce the i-th battle ship and this battle ship can make the tower loss li longevity every second when it has been produced. If the longevity of the tower lower than or equal to 0, the player wins. Notice that at each time, the factory can choose only one kind of battle ships to produce or do nothing. And producing more than one battle ships of the same kind is acceptable.

    Your job is to find out the minimum time the player should spend to win the game.

    Input

    There are multiple test cases. The first line of each case contains two integers N(1 ≤ N ≤ 30) and L(1 ≤ L ≤ 330), N is the number of the kinds of Battle Ships, L is the longevity of the Defense Tower. Then the following N lines, each line contains two integers t i(1 ≤ t i ≤ 20) and li(1 ≤ li ≤ 330) indicating the produce time and the lethality of the i-th kind Battle Ships.

    Output

    Output one line for each test case. An integer indicating the minimum time the player should spend to win the game.

    Sample Input

    1 1
    1 1
    2 10
    1 1
    2 5
    3 100
    1 10
    3 20
    10 100
    
    

    Sample Output

    2
    4
    5
    
    
    完全背包、注意理解
    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <vector>
    #include <cmath>
    #include <string>
    using namespace std;
    #define N 333
    
    int n,L;
    int dp[N];           //dp[j]表示时间为j时的最大攻击
    int t[N],l[N];
    
    int main()
    {
        int i,j;
        while(scanf("%d%d",&n,&L)!=EOF)
        {
            for(i=1;i<=n;i++)
            {
                scanf("%d%d",&t[i],&l[i]);
            }
            memset(dp,0,sizeof(dp));
            for(i=1;i<=n;i++)
            {
                for(j=t[i];j<=330;j++)
                {
                    dp[j]=max(dp[j],dp[j-t[i]]+(j-t[i])*l[i]);
                }
            }
            for(i=0;;i++)
            {
                if(dp[i]>=L)
                {
                    cout<<i<<endl;
                    break;
                }
            }
        }
        return 0;
    }
    趁着还有梦想、将AC进行到底~~~by 452181625
  • 相关阅读:
    外部排序
    oceanbase tpcc 关键总结
    TPCC测试
    最简单的oracle 19c安装教程
    unix进程环境
    tars以docker方式安装
    异常安全的赋值运算符函数
    linux 定时器setitimer使用
    libevent学习-reactor设计模式及代码示例
    linux中可执行程序搜索动态链接库的顺序
  • 原文地址:https://www.cnblogs.com/hate13/p/4139965.html
Copyright © 2011-2022 走看看