zoukankan      html  css  js  c++  java
  • hdu 1506

    Largest Rectangle in a Histogram

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 5335    Accepted Submission(s): 1523


    Problem Description
    A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles:

    Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.
     

     

    Input
    The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1 <= n <= 100000. Then follow n integers h1, ..., hn, where 0 <= hi <= 1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.
     

     

    Output
    For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.
     

     

    Sample Input
    7 2 1 4 5 1 3 3 4 1000 1000 1000 1000 0
     

     

    Sample Output
    8 4000

    #include<iostream>
    using namespace std;
    int
    n,i,a[100010],b[100010],c[100010];
    long long
    sum,m;
    int
    main()
    {

        c[0]=-1;
        while
    (scanf("%d",&n)!=EOF&&n>0)
        {

            for
    (i=1;i<=n;i++)
            {

                scanf("%d",&c[i]);
                a[i]=i;
                b[i]=i;
            }

            c[n+1]=-0x7fffffff;
            for
    (i=1;i<=n;i++)
            {

                while
    (c[a[i]-1]>=c[i])
                    a[i]=a[a[i]-1];
            }

            for
    (i=n;i>=1;i--)
            {

                while
    (c[b[i]+1]>=c[i])
                    b[i]=b[b[i]+1];
            }

            sum=-1;
            for
    (i=1;i<=n;i++)
            {

                m=b[i]-a[i]+1;
                m=m*c[i];
                if
    (m>sum) sum=m;
            }

            printf("%I64d\n",sum);
        }

        return
    0;
    }

  • 相关阅读:
    动手实现 Redux(六):Redux 总结
    动手实现 Redux(五):不要问为什么的 reducer
    动手实现 Redux(四):共享结构的对象提高性能
    动手实现 Redux(三):纯函数(Pure Function)简介
    动手实现 Redux(二):抽离 store 和监控数据变化
    动手实现 Redux(一):优雅地修改共享状态
    React.js 的 context
    高阶组件(Higher-Order Components)
    实战分析:评论功能(六)
    实战分析:评论功能(五)
  • 原文地址:https://www.cnblogs.com/hduacm/p/2623375.html
Copyright © 2011-2022 走看看