zoukankan      html  css  js  c++  java
  • hdu 1506

    Largest Rectangle in a Histogram

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 5335    Accepted Submission(s): 1523


    Problem Description
    A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles:

    Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.
     

     

    Input
    The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1 <= n <= 100000. Then follow n integers h1, ..., hn, where 0 <= hi <= 1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.
     

     

    Output
    For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.
     

     

    Sample Input
    7 2 1 4 5 1 3 3 4 1000 1000 1000 1000 0
     

     

    Sample Output
    8 4000

    #include<iostream>
    using namespace std;
    int
    n,i,a[100010],b[100010],c[100010];
    long long
    sum,m;
    int
    main()
    {

        c[0]=-1;
        while
    (scanf("%d",&n)!=EOF&&n>0)
        {

            for
    (i=1;i<=n;i++)
            {

                scanf("%d",&c[i]);
                a[i]=i;
                b[i]=i;
            }

            c[n+1]=-0x7fffffff;
            for
    (i=1;i<=n;i++)
            {

                while
    (c[a[i]-1]>=c[i])
                    a[i]=a[a[i]-1];
            }

            for
    (i=n;i>=1;i--)
            {

                while
    (c[b[i]+1]>=c[i])
                    b[i]=b[b[i]+1];
            }

            sum=-1;
            for
    (i=1;i<=n;i++)
            {

                m=b[i]-a[i]+1;
                m=m*c[i];
                if
    (m>sum) sum=m;
            }

            printf("%I64d\n",sum);
        }

        return
    0;
    }

  • 相关阅读:
    数组从文件中读取(接上问题)
    符合json格式要求的字符串转化为json字符串
    json-lib --->入门
    XStream-->别名;元素转属性;去除集合属性(剥皮);忽略不需要元素
    Ajax案例5-->省市联动
    Ajax案例4-->接收后台传递的XML数据
    Ajax案例3-->判断用户名是否被占用
    Ajax案例2-->POST请求
    Ajax案例1-->GET请求
    SecureCRT连接VMWare中的linux系统相关配置
  • 原文地址:https://www.cnblogs.com/hduacm/p/2623375.html
Copyright © 2011-2022 走看看