zoukankan      html  css  js  c++  java
  • BZOJ3942: [Usaco2015 Feb]Censoring 栈+KMP

    Description

    Farmer John has purchased a subscription to Good Hooveskeeping magazine for his cows, so they have plenty of material to read while waiting around in the barn during milking sessions. Unfortunately, the latest issue contains a rather inappropriate article on how to cook the perfect steak, which FJ would rather his cows not see (clearly, the magazine is in need of better editorial oversight).

    FJ has taken all of the text from the magazine to create the string S of length at most 10^6 characters. From this, he would like to remove occurrences of a substring T to censor the inappropriate content. To do this, Farmer John finds the _first_ occurrence of T in S and deletes it. He then repeats the process again, deleting the first occurrence of T again, continuing until there are no more occurrences of T in S. Note that the deletion of one occurrence might create a new occurrence of T that didn't exist before.

    Please help FJ determine the final contents of S after censoring is complete

    有一个S串和一个T串,长度均小于1,000,000,设当前串为U串,然后从前往后枚举S串一个字符一个字符往U串里添加,若U串后缀为T,则去掉这个后缀继续流程。

    
    
    

    Input

    The first line will contain S. The second line will contain T. The length of T will be at most that of S, and all characters of S and T will be lower-case alphabet characters (in the range a..z).
     

    Output

    The string S after all deletions are complete. It is guaranteed that S will not become empty during the deletion process.

    
    
    

    Sample Input

    whatthemomooofun
    moo

    Sample Output

    whatthefun

    Solution

    之前写过这题现在重新写了一遍qwq。

    研究一下这个删除就会发现如果你现在在$i$这个位置,那么你已经判断过的$1到i-1$是不会有什么影响的。

    那么其实可以拿个栈来维护,栈内放字符和匹配到这个字符时再模式串中的指针的位置。

    如果删除了一个数,把指针还原成当前栈顶的指针就好了。

    #include <bits/stdc++.h>
    using namespace std;
    
    #define ll long long
    #define inf 0x3f3f3f3f
    #define N 1000010
    
    int nxt[N];
    char s1[N], s2[N];
    struct Stack {
        char c;
        int now;
    }st[N];
    
    int main() {
        scanf("%s%s", s1 + 1, s2 + 1);
        int n = strlen(s1 + 1), m = strlen(s2 + 1);
        for(int i = 2, j = 0; i <= m; ++i) {
            while(j && s2[j + 1] != s2[i]) j = nxt[j];
            if(s2[j + 1] == s2[i]) ++j;
            nxt[i] = j;
        }
        int top = 0;
        for(int i = 1, j = 0; i <= n; ++i) {
            while(j && s2[j + 1] != s1[i]) j = nxt[j];
            if(s1[i] == s2[j + 1]) ++j;
            st[++top] = (Stack) {s1[i], j};
            if(j == m) top -= m, j = st[top].now;
        }
        for(int i = 1; i <= top; ++i) putchar(st[i].c);
        return 0;
    }
  • 相关阅读:
    让UIButton在按下时没有高亮效果
    如何让View一直沿z轴旋转
    App 应用通过网页打开 App Store
    Xcode/iOS: 如何判断代码运行在DEBUG还是RELEASE模式下?
    freemyapps 推荐链接
    [转]Git使用基础篇
    [转]anchorPoint 锚点解析
    Mac下如何看Swf文件
    Xcode 5: 将新项目同步到Svn上
    Shell 启动java程序
  • 原文地址:https://www.cnblogs.com/henry-1202/p/BZOJ4394.html
Copyright © 2011-2022 走看看