zoukankan      html  css  js  c++  java
  • ID Codes

    /*ID Codes Time Limit: 1000MS  Memory Limit: 10000K Total Submissions: 4928  Accepted: 2964

    Description

    It is 2084 and the year of Big Brother has finally arrived, albeit a century late. In order to exercise greater control over its citizens and thereby to counter a chronic breakdown in law and order, the Government decides on a radical measure--all citizens are to have a tiny microcomputer surgically implanted in their left wrists. This computer will contains all sorts of personal information as well as a transmitter which will allow people's movements to be logged and monitored by a central computer. (A desirable side effect of this process is that it will shorten the dole queue for plastic surgeons.)

    An essential component of each computer will be a unique identification code, consisting of up to 50 characters drawn from the 26 lower case letters. The set of characters for any given code is chosen somewhat haphazardly. The complicated way in which the code is imprinted into the chip makes it much easier for the manufacturer to produce codes which are rearrangements of other codes than to produce new codes with a different selection of letters. Thus, once a set of letters has been chosen all possible codes derivable from it are used before changing the set.

    For example, suppose it is decided that a code will contain exactly 3 occurrences of `a', 2 of `b' and 1 of `c', then three of the allowable 60 codes under these conditions are:

          abaabc       abaacb       ababac

    These three codes are listed from top to bottom in alphabetic order. Among all codes generated with this set of characters, these codes appear consecutively in this order.

    Write a program to assist in the issuing of these identification codes. Your program will accept a sequence of no more than 50 lower case letters (which may contain repeated characters) and print the successor code if one exists or the message `No Successor' if the given code is the last in the sequence for that set of characters.

    Input

    Input will consist of a series of lines each containing a string representing a code. The entire file will be terminated by a line consisting of a single #. Output

    Output will consist of one line for each code read containing the successor code or the words 'No Successor'. Sample Input

    abaacb cbbaa # Sample Output

    ababac No Successor

    */

    #include<iostream>
    #include<stdio.h>
    #include<algorithm>
    #include<cstring>
    #include<cmath>
    using namespace std;
    int main()
    {
    	char a[60];
    	int l,i;
    	while(scanf("%s",a))
    	{
    		i=0;
    		if(strcmp(a,"#")==0)
    			break;
    		l=strlen(a);
    		if(next_permutation(a,a+l)!=NULL)
    //自己想的,人才啊。。嘻嘻
    printf("%s\n",a); else printf("No Successor\n"); } return 0; }
  • 相关阅读:
    oracle_使用udev绑定磁盘方法
    Android studio实现简单的CRUD
    Android Studio无法打印Logout日志
    迭代法求平方根
    实现Hibernate框架的CRUD
    Android Studio连接真机调试
    Java项目学习笔记(一)
    绝对路径${pageContext.request.contextPath}
    request、response的setCharacterEncoding与response的setContentType
    java中的@Override标签
  • 原文地址:https://www.cnblogs.com/heqinghui/p/2606389.html
Copyright © 2011-2022 走看看