zoukankan      html  css  js  c++  java
  • Ignatius and the Princess III

    *Ignatius and the Princess III Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 7012    Accepted Submission(s): 4968

    Problem Description "Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

    "The second problem is, given an positive integer N, we define an equation like this:   N=a[1]+a[2]+a[3]+...+a[m];   a[i]>0,1<=m<=N; My question is how many different equations you can find for a given N. For example, assume N is 4, we can find:   4 = 4;   4 = 3 + 1;   4 = 2 + 2;   4 = 2 + 1 + 1;   4 = 1 + 1 + 1 + 1; so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"

    Input The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.

    Output For each test case, you have to output a line contains an integer P which indicate the different equations you have found.

    Sample Input 4 10 20  

    Sample Output 5 42 627 */

    #include<iostream>
    #include<stdio.h>
    using namespace std;
    //const int max=10001;//注意不能用这个
    #define max 10000000
    int c1[max];
    int
    c2[max];
    int
    main()
    {

        int
    i,j,k,n;
        while
    (scanf("%d",&n)!=EOF)
        {

            for
    (i=0;i<=n;i++)
                c1[i]=1;
            for
    (i=2;i<=n;i++)
            {

                for
    (j=0;j<=n;j++)
                    for
    (k=0;j+k<=n;k+=i)
                    c2[j+k]+=c1[j];
                for
    (j=0;j<=n;j++)
                {

                    c1[j]=c2[j];
                    c2[j]=0;
                }
            }

            printf("%d\n",c1[n]);
        }

        return
    0;
    }

  • 相关阅读:
    C#生成指定范围内的不重复随机数
    jquery移除元素某个属性
    让html里的js脚本延迟5秒运行
    jquery刷新局部和全页的方法
    jquery旋转插件rotate参数说明
    按照日期生成编号
    ajax请求成功后如何调用bootstrap modal?
    WPF MVVM模式不用Prism
    C#去掉字符串两端空格以及去掉字符串中多余空格保留一个空格
    依赖项属性
  • 原文地址:https://www.cnblogs.com/heqinghui/p/2612456.html
Copyright © 2011-2022 走看看