zoukankan      html  css  js  c++  java
  • 数组比较,查找,排序

    Problem G

    Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
    Total Submission(s) : 7   Accepted Submission(s) : 3

    Font: Times New Roman | Verdana | Georgia

    Font Size:

    Problem Description

    In millions of newspapers across the United States there is a word game called Jumble. The object of this game is to solve a riddle, but in order to find the letters that appear in the answer it is necessary to unscramble four words. Your task is to write a program that can unscramble words.

    Input

    The input contains four parts:
    1. a dictionary, which consists of at least one and at most 100 words, one per line; 2. a line containing XXXXXX, which signals the end of the dictionary; 3. one or more scrambled `words' that you must unscramble, each on a line by itself; and 4. another line containing XXXXXX, which signals the end of the file.
    All words, including both dictionary words and scrambled words, consist only of lowercase English letters and will be at least one and at most six characters long. (Note that the sentinel XXXXXX contains uppercase X's.) The dictionary is not necessarily in sorted order, but each word in the dictionary is unique.

    Output

    For each scrambled word in the input, output an alphabetical list of all dictionary words that can be formed by rearranging the letters in the scrambled word. Each word in this list must appear on a line by itself. If the list is empty (because no dictionary words can be formed), output the line ``NOT A VALID WORD" instead. In either case, output a line containing six asterisks to signal the end of the list.

    Sample Input

    tarp
    given
    score
    refund
    only
    trap
    work
    earn
    course
    pepper
    part
    XXXXXX
    resco
    nfudre
    aptr
    sett
    oresuc
    XXXXXX
    

    Sample Output

    score
    ******
    refund
    ******
    part
    tarp
    trap
    ******
    NOT A VALID WORD
    ******
    course
    ******
    

    #include<iostream>

    #include<stdio.h>

    #include <algorithm>

    #include<cstring>

    using namespace std;

    int main()

    {  

    int l=0,i=0,j=0,k=0,h,m,q,w,s,g;  

    char a[999][102],c[102],b[999][102],a1[999][102],d[999][102];  

    while(cin>>c)

     {  

     if(strcmp(c,"XXXXXX")==0)  

     {  

      l++;    if(l==2)     break;

      }   

    if(l==0&&strcmp(c,"XXXXXX"))  

     {

       strcpy(a[i],c);

       i++;    

    strcpy(a1[k],c);

       k++;   

    }

      if(l==1&&strcmp(c,"XXXXXX"))    strcpy(b[j++],c);

     }  

    for(h=0;h<k;h++)  

     sort(a1[h],a1[h]+strlen(a1[h]));

     for(m=0;m<j;m++)   

    sort(b[m],b[m]+strlen(b[m]));

     for(m=0;m<j;m++)  

    {  

     w=0;   q=0;   for(h=0;h<i;h++)

      {  

      if(strcmp(a1[h],b[m])==0)

       {    

     strcpy(d[w],a[h]);    

     w++;   

      q=1;   

     }

      }    

    if(h==i&&q==0)      

      cout<<"NOT A VALID WORD"<<endl;

       else   

     {    

     for(s=0;s<w;s++)    

      for(g=s+1;g<w;g++)   

        if(strcmp(d[s],d[g])>0)  

         {        

    strcpy(c,d[g]);     

       strcpy(d[g],d[s]);   

         strcpy(d[s],c);  

         }  

       for(s=0;s<w;s++)   

       cout<<d[s]<<endl;

       }    

    cout<<"******"<<endl;

     }    

    return 0;

    }

  • 相关阅读:
    vue cli 3 构建vue项目
    hadoop综合大作业
    理解Mapreduce
    熟悉常用的HBase操作
    常用的HDFS操作
    爬虫大作业
    数据结构化与保存
    爬取新闻
    网络爬虫基础练习
    Hadoop综合大作业
  • 原文地址:https://www.cnblogs.com/heqinghui/p/2613865.html
Copyright © 2011-2022 走看看