zoukankan      html  css  js  c++  java
  • POJ1979深搜问题

    Red and Black
    Time Limit: 1000MS  Memory Limit: 30000K 
    Total Submissions: 17584  Accepted: 9279 
    
    Description
    
    There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 
    
    Write a program to count the number of black tiles which he can reach by repeating the moves described above. 
    
    Input
    
    The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 
    
    There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 
    
    '.' - a black tile 
    '#' - a red tile 
    '@' - a man on a black tile(appears exactly once in a data set) 
    The end of the input is indicated by a line consisting of two zeros. 
    
    Output
    
    For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 
    Sample Input
    
    6 9
    ....#.
    .....#
    ......
    ......
    ......
    ......
    ......
    #@...#
    .#..#.
    11 9
    .#.........
    .#.#######.
    .#.#.....#.
    .#.#.###.#.
    .#.#..@#.#.
    .#.#####.#.
    .#.......#.
    .#########.
    ...........
    11 6
    ..#..#..#..
    ..#..#..#..
    ..#..#..###
    ..#..#..#@.
    ..#..#..#..
    ..#..#..#..
    7 7
    ..#.#..
    ..#.#..
    ###.###
    ...@...
    ###.###
    ..#.#..
    ..#.#..
    0 0
    Sample Output
    
    45
    59
    6
    13
    
    Source
    
    Japan 2004 Domestic
    
    
    
    #include<iostream>
    using namespace std;
    #define maxvex 21
    char c[maxvex][maxvex];
    struct {int x,y;}d[4]={{1,0},{-1,0},{0,1},{0,-1}};
    int ans,line,row,newx,newy;
    void find(int i,int j)
    {
        ans++;
        c[i][j]='#';
        for(int k=0;k<4;k++)
        {
            newx=i+d[k].x;
            newy=j+d[k].y;
            if(newx>=0&&newx<line&&newy>=0 && newy<row&&c[newx][newy]=='.')
                find(newx,newy);
        }
    }
    int main()
    {
        int i,j,tag;
        while(scanf("%d%d",&row,&line)&&line&&row)
        {
            tag=1;
            ans=0;
            for(i=0;i<line;i++)
                cin>>c[i];
            for(i=0;i<line;i++)
            {
                for(j=0;j<row;j++)
                    if(c[i][j]=='@')
                    {
                        find(i,j);
                        break;
                        tag=0;
                    }
                    if(tag==0)
                        break;
            }
        printf("%d\n",ans);
        }
        return 0;
    }
  • 相关阅读:
    NET5 WebApi 解决跨域问题
    CentOS7安装MYSQL
    VMWare安装CentOS7
    MSSQL还原数据库,更改用户登陆权限
    Vue自定义页面路由
    解决VSCODE"因为在此系统上禁止运行脚本"报错
    简析 HTTP 2.0 多路复用
    Git放弃本地修改,强制拉取最新版
    eclipse安装OpenExplorer插件--快速打开文件目录
    git统计某段时间内代码的修改量/总代码量
  • 原文地址:https://www.cnblogs.com/heqinghui/p/2762522.html
Copyright © 2011-2022 走看看