zoukankan      html  css  js  c++  java
  • 已知前序,中序,求后序

    Problem D 
    
    Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
    
    Total Submission(s) : 11   Accepted Submission(s) : 4
    
    Problem Description
     
    Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes.
     This is an example of one of her creations: 
                                                   D
                                                  / \
                                                 /   \
                                                B     E
                                               / \     \
                                              /   \     \
                                             A     C     G
                                                        /
                                                       /
                                                      F
     
    To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree). For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG.
     She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it).
     
    Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree.
     However, doing the reconstruction by hand, soon turned out to be tedious. 
    So now she asks you to write a program that does the job for her! 
    
    
     
    
    
    Input
     
    The input will contain one or more test cases. 
    Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.)
     Input is terminated by end of file. 
    
    
    
     
    
    
    Output
     
    For each test case, recover Valentine's binary tree and print one line containing the tree's postorder traversal (left subtree, right subtree, root). 
    
     
    
    
    Sample Input
    
    DBACEGF ABCDEFG
    BCAD CBAD
    
      
    
    
    Sample Output
    
    ACBFGED
    CDAB
    
    
    
    
    
    #include<iostream>
    #include<stdio.h>
    #include<string.h>
    using namespace std;
    #define MaxSize 100
    #define MaxWidth 40
    typedef char ElemType;
    typedef struct node
    {
        ElemType data;
        struct node *lchild;
        struct node *rchild;
    }BTNode;
    BTNode *CreateBT1(char *pre,char *in,int n)
    {
        BTNode *s;
        char *p;
        int k;
        if(n<=0)return NULL;
        s=new BTNode;
        s->data=*pre;
        for(p=in;p<in+n;p++)
            if(*p==*pre)
                break;
            k=p-in;
            s->lchild=CreateBT1(pre+1,in,k);
            s->rchild=CreateBT1(pre+k+1,p+1,n-k-1);
            return s;
    }
    void PostOrder(BTNode *b)
    {
        if(b!=NULL)
        {
            PostOrder(b->lchild);
            PostOrder(b->rchild);
            printf("%c",b->data);
        }
    }
    int main()
    {
        BTNode *root;
        char pr[30];
        char in[30];
        while(scanf("%s",pr)!=EOF&&scanf("%s",in)!=EOF)
        {
            if(!(strlen(pr)&&strlen(in)))
                break;
            root=CreateBT1(pr,in,strlen(pr));
            PostOrder(root);
            printf("\n");
        }
        return 0;
    }
  • 相关阅读:
    算法之递归
    初读 c# IL中间语言
    sql语句转为Model
    WPF-悬浮窗(类似于360)
    call,apply
    作用域题目
    css BFC
    数组扁平化 flatten
    常见的异步题
    setTimeout、Promise、Async/Await 的区别
  • 原文地址:https://www.cnblogs.com/heqinghui/p/2763531.html
Copyright © 2011-2022 走看看