zoukankan      html  css  js  c++  java
  • POJ3159:Candies(差分约束)

    Candies

    Time Limit: 1500MS   Memory Limit: 131072K
    Total Submissions: 39666   Accepted: 11168

    题目链接:http://poj.org/problem?id=3159

    Description:

    During the kindergarten days, flymouse was the monitor of his class. Occasionally the head-teacher brought the kids of flymouse’s class a large bag of candies and had flymouse distribute them. All the kids loved candies very much and often compared the numbers of candies they got with others. A kid A could had the idea that though it might be the case that another kid B was better than him in some aspect and therefore had a reason for deserving more candies than he did, he should never get a certain number of candies fewer than B did no matter how many candies he actually got, otherwise he would feel dissatisfied and go to the head-teacher to complain about flymouse’s biased distribution.

    snoopy shared class with flymouse at that time. flymouse always compared the number of his candies with that of snoopy’s. He wanted to make the difference between the numbers as large as possible while keeping every kid satisfied. Now he had just got another bag of candies from the head-teacher, what was the largest difference he could make out of it?

    Input:

    The input contains a single test cases. The test cases starts with a line with two integers N and M not exceeding 30 000 and 150 000 respectively. N is the number of kids in the class and the kids were numbered 1 through N. snoopy and flymouse were always numbered 1 and N. Then follow M lines each holding three integers AB and c in order, meaning that kid A believed that kid B should never get over c candies more than he did.

    Output:

    Output one line with only the largest difference desired. The difference is guaranteed to be finite.

    Sample Input:

    2 2
    1 2 5
    2 1 4

    Sample Output:

    5

    题意:

    给出n个点,m个关系,然后每个关系输入a,b,c,表示a+c>=b,a、b表示两个点,最后求出1和n最大差值为多少。

    题解:

    差分约束模板题= =直接建边跑最短路即可。

    代码如下:

    #include <cstdio>
    #include <cstring>
    #include <algorithm>
    #include <iostream>
    #include <queue>
    #define INF 0x3f3f3f3f
    using namespace std;
    typedef long long ll;
    const int N = 30005,M = 150005;
    int n,m;
    int head[N],vis[N],d[N];
    struct Edge{
        int u,v,w,next ;
    }e[M<<1];
    int tot;
    struct node{
        int d,u;
        bool operator < (const node &A)const{
            return d>A.d;
        }
    };
    void adde(int u,int v,int w){
        e[tot].v=v;e[tot].w=w;e[tot].next=head[u];head[u]=tot++;
    }
    void Dijkstra(int s){
        priority_queue <node> q;memset(d,INF,sizeof(d));
        memset(vis,0,sizeof(vis));d[s]=0;
        node now;
        now.d=0;now.u=s;
        q.push(now);
        while(!q.empty()){
            node cur = q.top();q.pop();
            int u=cur.u;
            if(vis[u]) continue ;
            vis[cur.u]=1;
            for(int i=head[u];i!=-1;i=e[i].next){
                int v=e[i].v;
                if(d[v]>d[u]+e[i].w){
                    d[v]=d[u]+e[i].w;
                    now.u=v;now.d=d[v];
                    q.push(now);
                }
            }
        }
    }
    int main(){
        cin>>n>>m;
        memset(head,-1,sizeof(head));
        for(int i=1;i<=m;i++){
            int u,v,c;
            scanf("%d%d%d",&u,&v,&c);
            adde(u,v,c);
        }
        Dijkstra(1);
        cout<<d[n];
        return 0;
    }
  • 相关阅读:
    23.C++- 继承的多种方式、显示调用父类构造函数、父子之间的同名函数、virtual虚函数
    22.C++- 继承与组合,protected访问级别
    LeetCode-391. 完美矩形(使用C语言编译,详解)
    LeetCode-101.对称二叉树
    STM32-对芯片启动读保护,实现加密(详解)
    21.C++- "++"操作符重载、隐式转换之explicit关键字、类的类型转换函数
    20.C++- "&&","||"逻辑重载操作符的缺陷、","逗号重载操作符的分析
    19.C++-(=)赋值操作符、初步编写智能指针
    18.C++-[ ]操作符使用 、函数对象与普通函数区别(详解)
    ECMAScript 6.0基础入门教程
  • 原文地址:https://www.cnblogs.com/heyuhhh/p/10351991.html
Copyright © 2011-2022 走看看